Bug 848310 - ovirt-engine-backend [QUOTA]: cannot edit a template's quota
ovirt-engine-backend [QUOTA]: cannot edit a template's quota
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Gilad Chaplik
Dafna Ron
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 04:55 EDT by Dafna Ron
Modified: 2016-02-10 15:17 EST (History)
8 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-08-15 04:55:14 EDT
Description of problem:

we cannot edit a template's quota for storage, the only way we can edit it is if we copy it to a different domain and than remove the orginal template. 

Version-Release number of selected component (if applicable):

si13.3

How reproducible:

100%

Steps to Reproduce:
1. create a template on quota1
2. go to template's tab/disks tab -> we have no way of editing the quota. 
3.
  
Actual results:

we cannot edit quota for templates disks 

Expected results:

to change quota we need a long work-a-round. 

Additional info:
Comment 1 Doron Fediuck 2012-08-15 06:08:57 EDT
Indeed this is a bad gap.
We'll add an "Assign Quota" button which will allow assigning a quota to the relevant template.
Comment 2 Gilad Chaplik 2012-08-23 08:41:57 EDT
currently added a button to disk main tab, where we can assign quota to disks.
TBD, where else we should add this button (both in VM and template disk subtabs), Doron?

merged upstream (http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=e8e0d6138e33708e94a39cbd067e0036f9f7d5f6)
Comment 4 Doron Fediuck 2012-08-23 11:57:26 EDT
(In reply to comment #2)
> currently added a button to disk main tab, where we can assign quota to
> disks.
> TBD, where else we should add this button (both in VM and template disk
> subtabs), Doron?
> 

That would be useful, yes.
Comment 5 Doron Fediuck 2012-08-23 11:59:22 EDT
We'll also need similar functionality to assign quota for VM's and templates, and not just disks.
Comment 6 Dafna Ron 2012-09-02 07:49:03 EDT
checked on si16

the assign quota button appears only in the disks tab. 
moving back to devel
Comment 7 Gilad Chaplik 2012-09-03 05:27:13 EDT
added the button to disk subtab in vm and template main tab:
merged upstream (http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=0f361d2e1bf9e4048209d74c7b0c79b6b2ab98b5)
Comment 10 Dafna Ron 2012-09-09 09:39:06 EDT
assign quota appears in all places - but we seem to have a refresh issue since it only appeared after I logged out -> logged in. 
however, it does appear under vm's disks tab, disks tab and under templates disks tab. 
verified on si17

Note You need to log in before you can comment on or make changes to this bug.