Bug 848315 - vdsm didn't filter out partitioned devices in getDeviceList
vdsm didn't filter out partitioned devices in getDeviceList
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Aharon Canan
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 05:06 EDT by haiyang,dong
Modified: 2016-02-10 13:02 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 08:05:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
all luns are listed (36.77 KB, image/png)
2012-08-15 05:25 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-08-15 05:06:58 EDT
Description of problem:
Add storage in rhevm, the lun which have rhev-h installed on isn't filtered out, all luns are listed there.


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120813.0.rhev31.el6_3
vdsm-4.9.6-27.0.el6_3.x86_64
rhevm-si14 (rhevm-3.1.0-12.el6ev.noarch)

How reproducible:
Always.

Steps to Reproduce:
1. Register a host which have multi luns to RHEVM.
2. Approve host on RHEVM.
3. Add storage for the cluster which rhev-h node in.

Actual results:
the lun which have rhev-h installed on isn't filtered out, all luns are listed there.

Expected results:
the lun have rhev-h installed on should not list there.

Additional info: 
[root@dell-pet105-01 admin]# pvs
  
  PV                                              VG                                   Fmt  Attr PSize  PFree 
  /dev/mapper/3600a0b80005adb0b00004d674f0b72b0p4 HostVG                               lvm2 a--  19.28g     0 
  /dev/mapper/3600a0b80005adb0b00004d834f0b7954   33312a31-1ca7-487c-baf3-b5284521064c lvm2 a--  29.62g 25.75g

[root@dell-pet105-01 admin]# multipath -ll
3600a0b80005adb0b00004d674f0b72b0 dm-0 IBM,1726-4xx  FAStT
size=20G features='1 queue_if_no_path' hwhandler='1 rdac' wp=rw
|-+- policy='round-robin 0' prio=6 status=active
| |- 6:0:1:0 sdc 8:32  active ready running
| `- 7:0:3:0 sdg 8:96  active ready running
`-+- policy='round-robin 0' prio=1 status=enabled
  |- 6:0:0:0 sda 8:0   active ghost running
  `- 7:0:1:0 sde 8:64  active ghost running
3600a0b80005adb0b00004d834f0b7954 dm-1 IBM,1726-4xx  FAStT
size=30G features='1 queue_if_no_path' hwhandler='1 rdac' wp=rw
|-+- policy='round-robin 0' prio=6 status=active
| |- 6:0:1:1 sdd 8:48  active ready running
| `- 7:0:3:1 sdh 8:112 active ready running
`-+- policy='round-robin 0' prio=1 status=enabled
  |- 6:0:0:1 sdb 8:16  active ghost running
  `- 7:0:1:1 sdf 8:80  active ghost running
Comment 1 Yaniv Kaul 2012-08-15 05:09:54 EDT
Is the LUN visible, and not 'in use' in the webui?
Comment 3 Haim 2012-08-15 05:25:14 EDT
please provide full vdsm log and output of vdsClient 0 getDeviceList. 
iirc, this is by design, and i'll explain:

- vdsm should report the lun as used 
- web-ui should report the lun as used but not filter it out - instead, there is a new column called 'in use', and a pop-up will be shown if you chose this device.
Comment 4 haiyang,dong 2012-08-15 05:25:56 EDT
Created attachment 604559 [details]
all luns are listed
Comment 6 Itamar Heim 2012-08-15 05:34:30 EDT
yes, and it says in used: used
and it is grayed out.
see bug 724807 for more details
Comment 12 Ayal Baron 2012-08-17 18:00:59 EDT
Greying out is a GUI function, not vdsm.
Moving to relevant component.
Comment 18 Ayal Baron 2013-07-17 08:05:47 EDT
How do you determine whether the device is in use by HostVG? (note that user can change the name).  It's always a heuristic and not that interesting really.

Also, if you try to use it it will fail.

Note You need to log in before you can comment on or make changes to this bug.