Bug 848332 - DNS resolution failures during multiple graph changes
DNS resolution failures during multiple graph changes
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: fuse (Show other bugs)
2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Raghavendra G
shylesh
:
Depends On: 796614
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 05:41 EDT by Vidya Sakar
Modified: 2013-09-23 18:36 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 796614
Environment:
Last Closed: 2013-09-23 18:36:17 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-15 05:41:21 EDT
+++ This bug was initially created as a clone of Bug #796614 +++

Description of problem: While running volume set commands in a loop, DNS resolution failures were seen in the logs after a while. the I/O on the mount point exited reporting ENOTCONN. 


Version-Release number of selected component (if applicable): 3.3.0qa23


How reproducible: regularly


Steps to Reproduce:
1. Running volume set commands in a loop

Actual results:

[2012-02-23 15:44:14.463021] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-02-23 15:44:15.701915] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-02-23 15:44:15.957471] E [common-utils.c:135:gf_resolve_ip6] 505-resolver: getaddrinfo failed (Name or service not known)
[2012-02-23 15:44:15.957521] E [name.c:254:af_inet_client_get_remote_sockaddr] 505-test2-client-0: DNS resolution failed on host shortwing
[2012-02-23 15:44:15.957587] W [client.c:2011:client_rpc_notify] 505-test2-client-0: Registering a grace timer
[2012-02-23 15:44:15.957644] E [common-utils.c:135:gf_resolve_ip6] 506-resolver: getaddrinfo failed (Name or service not known)
[2012-02-23 15:44:15.957658] E [name.c:254:af_inet_client_get_remote_sockaddr] 506-test2-client-0: DNS resolution failed on host shortwing
[2012-02-23 15:44:15.957679] W [client.c:2011:client_rpc_notify] 506-test2-client-0: Registering a grace timer
[2012-02-23 15:44:16.942944] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-02-23 15:44:18.201403] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-02-23 15:44:18.958462] E [common-utils.c:135:gf_resolve_ip6] 505-resolver: getaddrinfo failed (Name or service not known)
[2012-02-23 15:44:18.958508] E [name.c:254:af_inet_client_get_remote_sockaddr] 505-test2-client-0: DNS resolution failed on host shortwing
[2012-02-23 15:44:18.958590] E [common-utils.c:135:gf_resolve_ip6] 506-resolver: getaddrinfo failed (Name or service not known)
[2012-02-23 15:44:18.958604] E [name.c:254:af_inet_client_get_remote_sockaddr] 506-test2-client-0: DNS resolution failed on host shortwing
[2012-02-23 15:44:19.411039] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed
[2012-02-23 15:44:20.642095] I [glusterfsd-mgmt.c:64:mgmt_cbk_spec] 0-mgmt: Volume file changed


Expected results:


Additional info:
Comment 2 Amar Tumballi 2012-08-23 02:45:16 EDT
This bug is not seen in current master branch (which will get branched as RHS 2.1.0 soon). To consider it for fixing, want to make sure this bug still exists in RHS servers. If not reproduced, would like to close this.
Comment 4 shylesh 2013-08-23 13:00:18 EDT
verified on 3.4.0.22rhs-2.el6rhs.x86_64. 
No error message appears upon executing above said steps and I/O will not fail.
Comment 5 Scott Haines 2013-09-23 18:36:17 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.