Bug 8485 - configure options --with-debug and --with-profile are a bad
configure options --with-debug and --with-profile are a bad
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-15 00:14 EST by andrewem
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-17 08:19:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrewem 2000-01-15 00:14:16 EST
--with-debug is a bad configure option since everything is stripped in
%install  This can also cause a lot of warning messages because it causes
-g to be specified which is incompatible with -fomit-frame-pointer

--with-profile is a bad configure option since there is no debug symbols
(again, they are stripped in %install) and profiling is incompatible with
-fomit-frame-pointer

They aren't needed on any architecture.  They cause problems when using
-fomit-frame-pointer in %optflags.  Please get rid of them.

Thanks.
Comment 1 Bernhard Rosenkraenzer 2000-01-17 08:19:59 EST
Actually that has been done for quite some time.
It was the first thing I did when I took over the ncurses package. ;)

Note You need to log in before you can comment on or make changes to this bug.