Bug 848502 - pkcon help says refresh [--force] incorrectly
pkcon help says refresh [--force] incorrectly
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.0
x86_64 Linux
unspecified Severity low
: rc
: 7.0
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 15:11 EDT by Vladimir Benes
Modified: 2012-11-01 06:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 06:09:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-08-15 15:11:36 EDT
Description of problem:
pkcon help says refresh [--force] but it should say [force] only. In older version both --force and force worked but now (F17) just force works.

Version-Release number of selected component (if applicable):
PackageKit-0.7.4-5.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.excute 'pkcon --help' 
2.execute 'pkcon refresh --force
3.
  
Actual results:
there is a [--force] option in refresh and the second command says option not available

Expected results:
help should be consistent with cli options

Additional info:
Comment 1 Richard Hughes 2012-11-01 06:09:49 EDT
commit d25058ef6ae2c9eac9cb713ecf013d0beaf51831
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Nov 1 10:12:21 2012 +0000

    Do not use --force for 'pkcon refresh' it gets swallowed by the option parser
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=848502

Note You need to log in before you can comment on or make changes to this bug.