Bug 848513 - [abrt] python-2.7.3-7.2.fc17: virNetClientCallQueue: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] python-2.7.3-7.2.fc17: virNetClientCallQueue: Process /usr/bin/python2...
Status: CLOSED DUPLICATE of bug 836684
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
abrt_hash:4f265205a39f47ccef37d3c698e...
:
: 853547 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 15:33 EDT by Brian J. Murrell
Modified: 2012-10-19 15:46 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 15:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (81.84 KB, text/plain)
2012-08-15 15:33 EDT, Brian J. Murrell
no flags Details
File: maps (91.21 KB, text/plain)
2012-08-15 15:33 EDT, Brian J. Murrell
no flags Details
File: dso_list (19.17 KB, text/plain)
2012-08-15 15:33 EDT, Brian J. Murrell
no flags Details
File: build_ids (7.89 KB, text/plain)
2012-08-15 15:33 EDT, Brian J. Murrell
no flags Details

  None (edit)
Description Brian J. Murrell 2012-08-15 15:33:16 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        python /usr/share/virt-manager/virt-manager.py
crash_function: virNetClientCallQueue
executable:     /usr/bin/python2.7
kernel:         3.3.4-5.fc17.x86_64
pid:            23241
pwd:            /home/brian
remote_result:  831441
time:           Wed 15 Aug 2012 01:54:09 PM EDT
uid:            1001
username:       brian
var_log_messages: Aug 15 13:54:11 brian-laptop abrt[20316]: Saved core dump of pid 23241 (/usr/bin/python2.7) to /var/spool/abrt/ccpp-2012-08-15-13:54:09-23241 (432431104 bytes)

backtrace:      Text file, 83807 bytes
build_ids:      Text file, 8077 bytes
dso_list:       Text file, 19633 bytes
maps:           Text file, 93400 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/brian/84

core_backtrace:
:50f16df934d0d9b1235796d014157733fda755c5 0x126463 - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x12772b - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x127f1b - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x10a9e8 - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0x10dace - libvirt.so.0 -
:50f16df934d0d9b1235796d014157733fda755c5 0xf7beb virDomainHasManagedSaveImage libvirt.so.0 -
:8cf0174067d9a514f4f28d05d185e0ad3c333cbe 0x279ce libvirt_virDomainHasManagedSaveImage libvirtmod.so -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xdd0e1 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xdcd51 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xdcd51 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xddb1f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0x6d796 - libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0x58070 - libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xd71c7 PyEval_CallObjectWithKeywords libpython2.7.so.1.0 -
:fac447a0873707c61a7ccabb85d63cc13c768dad 0x18de1 - _gobject.so -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x206d8 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x261fe1 - libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2660f0 - libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14db4c - libgtk-x11-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x20450 - libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x282a7 g_signal_emit_valist libgobject-2.0.so.0 -
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x2815ae - libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14b914 gtk_propagate_event libgtk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14bc7b gtk_main_do_event libgtk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x61edc - libgdk-x11-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0x14ac57 gtk_main libgtk-x11-2.0.so.0 -
:e4ee09219dd69e5a1f6b06fb78c7488a3a6260df 0x1a65a8 - _gtk.so -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xdce36 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xdcd51 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xddb1f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xddbf2 PyEval_EvalCode libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xf6b9a - libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xf7992 PyRun_FileExFlags libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0xf83ab PyRun_SimpleFileExFlags libpython2.7.so.1.0 -
:b18586fcfc52cc29c9623ef45ad533e2ba1f2f37 0x109882 Py_Main libpython2.7.so.1.0 -

environ:
:XDG_VTNR=3
:SSH_AGENT_PID=26770
:XDG_SESSION_ID=84
:HOSTNAME=brian-laptop
:GIO_LAUNCHED_DESKTOP_FILE_PID=23235
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/brian/keyring-tUEluL/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/run/user/brian/keyring-tUEluL
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=brian
:SSH_AUTH_SOCK=/run/user/brian/keyring-tUEluL/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/26646,unix/unix:/tmp/.ICE-unix/26646
:USERNAME=brian
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/virt-manager.desktop
:PATH=/home/brian/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/home/brian/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:DESKTOP_SESSION=cinnamon
:MAIL=/var/spool/mail/brian
:LC_MESSAGES=en_CA.UTF-8
:_=/usr/bin/gnome-session
:QT_IM_MODULE=xim
:LC_COLLATE=en_CA.UTF-8
:PWD=/home/brian
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=cinnamon
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/brian
:SHLVL=1
:LANGUAGE=en_CA:en
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=brian
:LC_CTYPE=en_CA.UTF-8
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ygwmG3l1a0,guid=e62e7091b485d57863442867000433b1
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=3
:XDG_RUNTIME_DIR=/run/user/brian
:DISPLAY=:0
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/var/run/gdm/auth-for-brian-aGpYUH/database

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63196                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63196                63196                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:/home/brian/.virt-manager/virt-manager.log
:pos:	613076
:flags:	0102001
:4:socket:[49492622]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:/dev/urandom
:pos:	0
:flags:	02100000
:7:socket:[49492619]
:pos:	0
:flags:	02000002
:8:socket:[49492623]
:pos:	0
:flags:	02004002
:9:socket:[49493319]
:pos:	0
:flags:	02004002
:10:socket:[49492626]
:pos:	0
:flags:	02004002
:11:pipe:[49324818]
:pos:	0
:flags:	00
:12:pipe:[49324818]
:pos:	0
:flags:	04001
:13:socket:[49306099]
:pos:	0
:flags:	02004002
:14:pipe:[49306100]
:pos:	0
:flags:	02000000
:15:pipe:[49306100]
:pos:	0
:flags:	02000001
:16:socket:[49546770]
:pos:	0
:flags:	02004002
:17:pipe:[49571808]
:pos:	0
:flags:	02000000
:18:pipe:[49571808]
:pos:	0
:flags:	02000001
:19:anon_inode:inotify
:pos:	0
:flags:	02004000
:20:socket:[72332674]
:pos:	0
:flags:	02004002
:21:socket:[72375182]
:pos:	0
:flags:	02004002
:22:pipe:[72375183]
:pos:	0
:flags:	02000000
Comment 1 Brian J. Murrell 2012-08-15 15:33:20 EDT
Created attachment 604679 [details]
File: backtrace
Comment 2 Brian J. Murrell 2012-08-15 15:33:22 EDT
Created attachment 604680 [details]
File: maps
Comment 3 Brian J. Murrell 2012-08-15 15:33:24 EDT
Created attachment 604681 [details]
File: dso_list
Comment 4 Brian J. Murrell 2012-08-15 15:33:25 EDT
Created attachment 604682 [details]
File: build_ids
Comment 5 Thomas Spura 2012-08-15 16:22:42 EDT
As the crash is deep inside of libvirt, reassigning to libvirt
and wondering why "virNetClientCallPtr call" is not "virNetClientCall call" in the crashing function...
Comment 6 Thomas Spura 2012-08-31 16:34:36 EDT
*** Bug 853547 has been marked as a duplicate of this bug. ***
Comment 7 Cole Robinson 2012-10-19 15:46:19 EDT
Pretty sure this is fixed by latest libvirt in F17

*** This bug has been marked as a duplicate of bug 836684 ***

Note You need to log in before you can comment on or make changes to this bug.