Bug 848611 - Show error message in rhc domain show
Show error message in rhc domain show
Status: CLOSED DUPLICATE of bug 847723
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 22:00 EDT by Rony Gong
Modified: 2015-05-14 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 13:50:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-08-15 22:00:35 EDT
Description of problem:
This error only happened for scalable app, maybe caused by fix bug
https://bugzilla.redhat.com/show_bug.cgi?id=847723


Version-Release number of selected component (if applicable):
rhc-0.97.7, devenv_1995


How reproducible:
always


Steps to Reproduce:
1.Create Scalable app and embed mongodb, mysql
2.rhc domain show
3.If create more apps, rhc domain show still only show this app. 
  
Actual results:
[rony@localhost dev]$ rhc domain show

User Info
=========
Namespace: qgong4

Login: qgong@redhat.com

Namespace qgong4's Applications
===============================
qsphp
    Framework: php-5.3
     Creation: 2012-08-15T21:26:23-04:00
         UUID: b51e0a1213244040b90d9516924c0769
      Git URL: ssh://b51e0a1213244040b90d9516924c0769@qsphp-qgong4.dev.rhcloud.com/~/git/qsphp.git/
   Public URL: http://qsphp-qgong4.dev.rhcloud.com/
     Embedded:
       mongodb-2.0 - mongodb://eade9167e2-qgong4.dev.rhcloud.com:35551/
       mysql-5.1 - mysql://15604262d0-qgong4.dev.rhcloud.com:35546/
RESULT:
error: undefined method `[]' for nil:NilClass Use --trace to view backtrace.



Expected results:
"error: undefined method `[]' for nil:NilClass Use --trace to view backtrace"

this message should be replaced by success.


Additional info:
Comment 1 Rony Gong 2012-08-16 01:52:13 EDT
(In reply to comment #0)
> Description of problem:
> This error only happened for scalable app, maybe caused by fix bug

Sorry, this error also happened for non-scalable app.
Comment 2 John (J5) Palmieri 2012-08-16 13:40:49 EDT
*** Bug 847723 has been marked as a duplicate of this bug. ***
Comment 3 John (J5) Palmieri 2012-08-16 13:50:52 EDT

*** This bug has been marked as a duplicate of bug 847723 ***

Note You need to log in before you can comment on or make changes to this bug.