Bug 848619 - No message displayed to ask user to change the config file after updating domain successfully
No message displayed to ask user to change the config file after updating dom...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 23:34 EDT by joycezhang
Modified: 2015-05-14 22:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhc-0.97.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2012-08-15 23:34:14 EDT
Description of problem:
No message is displayed to ask user modifying config file with latest domain name replaced. There's only one "Success" displayed as below:

# rhc domain update -n jinzhang3 -p a

Updating domain 'jinzhang2' to namespace 'jinzhang3'

RESULT:
Success!


Version-Release number of selected component (if applicable):
rhc-0.97.7.gem
devenv_1995


How reproducible:
always


Steps to Reproduce:
1.Create some apps
2.Update domain name:
#rhc domain update -n newdomain -p xxx

  
Actual results:
Only a "Sucess" is displayed, user will get git push failed without modifying new namespace in config file.
# rhc domain update -n jinzhang3 -p a

Updating domain 'jinzhang2' to namespace 'jinzhang3'

RESULT:
Success!


Expected results:
An friendly message shoud pop up to ask user changing the config file with latest domain name instead before using git push.


Additional info:
This message can be shown with old rhc client.
Comment 1 Clayton Coleman 2012-08-16 10:50:06 EDT
We should update the config automatically on a rename if and only if it is configured in the config.
Comment 2 John (J5) Palmieri 2012-08-16 13:23:50 EDT
we can't update the git config on the users side since their apps could be anywhere on the file system.  .git/config is also a local file so changing it on the server won't help either.  A message is the only way to fix this.
Comment 3 joycezhang 2012-08-16 22:26:48 EDT
This bug has been verified and fixed.

Please refer to the following details:

Build:
int.openshift.redhat.com
rhc-0.97.11.gem

Steps:
1. Update domain name:
# rhc domain update test8 
Password: ******


Updating domain 'testdm6' to namespace 'test8'

RESULT:
Success!
You can use 'rhc domain show' to view any url changes.  Be sure to update any links including the url in your local git config: <local_git_repo>/.git/config

A reasonable message is shown to ask user modifying the config file.

So it's fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.