Bug 848661 - confusing warning message when adding jenkins client to an app
confusing warning message when adding jenkins client to an app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 03:16 EDT by Meng Bo
Modified: 2015-05-14 18:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: AMI devenv_2024
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-08-16 03:16:44 EDT
Description of problem:
Jenkins server new created, app new created, add jenkins client to the app, will get some warning about "Associated with existing job 'php1-build' in Jenkins server."

Version-Release number of selected component (if applicable):
cartridge-jenkins-1.4-0.97.1-1.git.0.349a91c.el6.noarch
cartridge-jenkins-client-1.4-0.31.2-1.git.0.05990dc.el6.noarch
devenv_1997
rhc-0.97.7

How reproducible:
always

Steps to Reproduce:
1.Create a jenkins app
2.Create an app of any type
3.Embed the jenkins client to the app
$rhc app cartridge add -a app1 -c jenkins-client-1.4 
  
Actual results:
$rhc app cartridge add -a php1 -c jenkins-client-1.4
RESULT:

Associated with existing job 'php1-build' in Jenkins server.
If this was not intended you can remove the jenkins client, remove or rename 
the existing job, and re-add the jenkins client to get a new job created.

Job URL: https://jk1-bmengdev.dev.rhcloud.com/job/php1-build/

Jenkins client 1.4 has been added to: php1


Expected results:
Should not have the warning about exsiting job since the jenkins server is new created, and doesn't have such job actually.

Additional info:
Comment 1 Bill DeCoste 2012-08-16 14:22:45 EDT
The Job gets created for each application, in this case "php1-build" is the name of the Job in Jenkins. 

How about I just get rid of "existing" since that's confusing?
Comment 2 Meng Bo 2012-08-16 21:40:21 EDT
Hi Bill,

I think the whole sentence should not show up when the app embed jenkins for the first time.
In the past, this warning show up when user removed the embedded jenkins client from existed apps and try to add the jenkins client to the same apps again.
Comment 3 Jianwei Hou 2012-08-21 06:06:56 EDT
Verified on devenv_2042


Steps:
1.Create a jenkins server
2.Create an application and embed jenkins-client, check output

RESULT:

Associated with job 'ps1-build' in Jenkins server.

Job URL: https://jks-2042t1.dev.rhcloud.com/job/ps1-build/

Jenkins client 1.4 has been added to: ps1

Note You need to log in before you can comment on or make changes to this bug.