Bug 848678 - Nothing happened to click menu "Help -> About" in subscription-manager-gui
Nothing happened to click menu "Help -> About" in subscription-manager-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-16 04:04 EDT by xingge
Modified: 2016-09-19 22:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
subscription-manager-gui menu error's log (6.40 KB, text/x-log)
2012-08-16 04:04 EDT, xingge
no flags Details
help menu (150.27 KB, image/png)
2012-08-17 07:25 EDT, Shwetha Kallesh
no flags Details
help menu from brew (202.11 KB, image/png)
2012-08-24 11:49 EDT, J.C. Molet
no flags Details

  None (edit)
Description xingge 2012-08-16 04:04:07 EDT
Created attachment 604809 [details]
subscription-manager-gui menu error's log

Description of problem:
Click menu "Help->About" in subscription-manager-gui, nothing happened.  

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
python-rhsm-1.0.5-1.el5

How reproducible:
always

Steps to Reproduce:
1.open the subscription manager GUI
#subscription-manager-gui
2.Click menu item Help->About to show the About Subscription Manager 
  
Actual results:
After above step 2, nothing will display, and below error message shows in the Terminal:
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 426, in _about_item_clicked
    about = AboutDialog(self._get_window(), self.backend)
  File "/usr/share/rhsm/subscription_manager/gui/about.py", line 60, in __init__
    self.dialog.set_version(server_versions['subscription manager'])
KeyError: 'subscription manager'

Expected results:
The "About Subscription Manager" panel should display.

Additional info:
Comment 1 Bryan Kearney 2012-08-16 12:59:33 EDT
this was fixed in 1f95960919aab17057837a954874d944c3ed2b59 in master. Should be availablein 1.0.14.
Comment 2 Shwetha Kallesh 2012-08-17 07:25:08 EDT
Created attachment 605188 [details]
help menu

marking verified

[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5
Comment 3 Keqin Hong 2012-08-17 07:51:13 EDT
(In reply to comment #2)
> Created attachment 605188 [details]
> help menu
> 
> marking verified
> 
> [root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
> subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
> subscription-manager-1.0.13-1.git.45.5cb55c8.el5
> subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
> subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
> subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5

Hi Shwetha,

Following CDW, we should wait PM, Dev, QE to do 3ack of this bug first, then wait till the bug's status changed to "ON_QA". After that we can verify this bug and move its status to "VERIFIED".

I see you moved its status to VERIFIED based on the test result of upstream build. Yet, there is a risk in doing this way. We don't know if this is finally fixed on formal rpm build. There's possibility that some patches are removed or missed on RHEL build.

I suggest we don't move its status to VERIFIED until it is verified on next formal RPM build. So, right now I move its status back to ASSIGNED.

Regards,
Keqin
Comment 4 RHEL Product and Program Management 2012-08-17 07:57:04 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Bryan Kearney 2012-08-17 12:48:39 EDT
The fix is in, moving to MODIFIED so that it can be moved to ON_QA by errata.
Comment 7 J.C. Molet 2012-08-24 11:49:45 EDT
Created attachment 606905 [details]
help menu from brew

subscription-manager-migration-data-1.11.2.3-1.el5
subscription-manager-gui-1.0.14-1.el5
subscription-manager-migration-1.0.14-1.el5
python-rhsm-1.0.5-1.el5
subscription-manager-firstboot-1.0.14-1.el5
subscription-manager-1.0.14-1.el5

^^^^
Testing with all the sub-man bits in brew.

The menu now pops up (both by clicking and keyboard shortcut) and produces no traceback.

Marking VERIFIED.
Comment 9 errata-xmlrpc 2013-01-07 22:59:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.