Red Hat Bugzilla – Bug 848699
php-geshi requires "php" package
Last modified: 2013-10-23 13:42:12 EDT
Description of problem:
Shall php-geshi require php-common instead of php?
Version-Release number of selected component (if applicable):
yum install php-geshi
Processing Dependency: php >= 4.3.0 for package: php-geshi-18.104.22.168-1.el6.noarch
Processing Dependency: php-common for package: php-geshi
From PHP Guidelines
> A PHP library must not have an explicit Requires on php or httpd, since these
> libraries could be used with any webserver or any SAPI (php-cli, php-cgi,
> php-fpm, ...).
Proposal : simply drop this line (4.3.0 is far behind all available version in Fedora/EL supported versions)
Could also add php-date and php-pcre.
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.
(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)
More information and reason for this action is here:
Thanks for the report and sorry for the late reply, this should have been closed long ago, this was fixed on August 21st 2012 with php-geshi 22.214.171.124-1.