Bug 848721 - A new package usbclerk-win
A new package usbclerk-win
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
3.1.0
Unspecified Windows
unspecified Severity unspecified
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 05:44 EDT by Uri Lublin
Modified: 2013-08-25 20:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: usbclerk-win-0.1-5
Doc Type: Bug Fix
Doc Text:
Cause: This issue is caused by improper installation and uninstallation of USB drivers. Consequence: After a remote-viewer client is closed while a USB device is connected to a client machine, it becomes impossible to use the USB device on the client machine. Fix: A new package, usbclerk, temporary installs usb drivers on a per-session basis. When the session is concluded, usbclerk uninstalls the usb drivers. Result: USB drivers no longer remain installed on client machines after remote-viewer clients are closed, and client machines regain access to their USB drives at the conclusion of a remote-viewer session. (BZ#848721)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:58:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uri Lublin 2012-08-16 05:44:08 EDT
Description of problem:
A new service, usbclerk, that knows how to install/uninstall Windows usb drivers (specifically the WinUSB driver).

Spice client (mingw-virt-viewer) send requests to install/uninstall the driver for USB devices when users connecting/disconnecting a USB device to a guest (aka usbredir)
Comment 6 errata-xmlrpc 2012-12-04 12:58:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1527.html

Note You need to log in before you can comment on or make changes to this bug.