Bug 848736 - Segfaults in libresolv-2.15.so with hesiod
Segfaults in libresolv-2.15.so with hesiod
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 06:26 EDT by Tomas Smetana
Modified: 2016-11-24 10:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 09:54:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Segfault backtrace (5.35 KB, text/plain)
2012-08-16 06:26 EDT, Tomas Smetana
no flags Details

  None (edit)
Description Tomas Smetana 2012-08-16 06:26:42 EDT
Created attachment 604877 [details]
Segfault backtrace

Description of problem:
When using hesiod as the passwd/group database, some applications, most notably those of shadow-utils segfault in libresolv.

Version-Release number of selected component (if applicable):
glibc-2.15-51.fc17.x86_64
shadow-utils-4.1.4.3-14.fc17.x86_64
hesiod-3.1.0-21.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. I use dnsmasq configured like this (/etc/dnsmasq.conf):

no-resolv
no-poll
server=<your usual DNS server>
txt-record=testgrp.group.ns.example.com,"testgrp:x:2001:root"
txt-record=2001.group.ns.example.com,"testgrp:x:2001:root"
txt-record=2001.gid.ns.example.com,"testgrp:x:2001:root"

2. Change nsswitch.conf to query hesiod for the group records -- change the group configuration so it looks like this:

group:      files hesiod

3. Configure hesiod (/etc/hesiod.conf):
lhs=.ns
rhs=.example.com
classes=IN,HS

4. Configure resolver to query the local dnsmasq (/etc/resolv.conf):
nameserver 127.0.0.1

5. useradd -M testuser

Actual results:
Segmentation fault

Expected results:
The new account is created

Additional info:
The /var/log/messages contain this error:
Aug 16 12:10:36 f-17 kernel: [ 4966.543583] useradd[2829]: segfault at 0 ip 00007fea08e72b34 sp 00007fff65bd6350 error 4 in libresolv-2.15.so[7fea08e69000+16000]

I have added a backtrace (in attachment).

I was not able to reproduce this bug on Rawhide.  Also -- I'm not entirely sure this is a glibc problem but looking a the changes made in shadow-utils between F-17 and Rawhide makes glibc the main suspect.

Please let me know if you need some additional information.
Comment 1 Jeff Law 2012-08-16 12:02:26 EDT
Tomas, can you try the pending update (.56).  This really looks like fallout from the broken "fixes" that were made to res_send and which were recently fixed (partially in .52, then fully in .55).

https://admin.fedoraproject.org/updates/FEDORA-2012-11927/glibc-2.15-56.fc17
Comment 2 Tomas Smetana 2012-08-17 03:55:50 EDT
Hello,
 the .56 version really fixed the problem.

Thank you.
Comment 3 Jeff Law 2012-08-17 09:54:21 EDT
Thanks for verifying.

Note You need to log in before you can comment on or make changes to this bug.