Bug 848769 - Username same as environment can be created in SAM1.2
Username same as environment can be created in SAM1.2
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sammons
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 07:32 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-02 10:22:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
User name similar to Environment name (57.61 KB, image/png)
2012-08-16 07:32 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-08-16 07:32:55 EDT
Created attachment 604895 [details]
User name similar to Environment name

Description of problem:
A user name similar to that of environment can be created .


Version-Release number of selected component (if applicable):
[root@dell-pesc1435-01 ~]# rpm -qa | grep katello
katello-all-1.0.5-1.fc16.noarch
katello-glue-candlepin-1.0.5-1.fc16.noarch
katello-configure-1.1.3-1.fc16.noarch
katello-glue-pulp-1.0.5-1.fc16.noarch
katello-1.0.5-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-selinux-1.0.1-1.fc16.noarch
katello-cli-headpin-1.1.0-1.git.14.d10e8a3.fc16.noarch
katello-glue-foreman-1.0.5-1.fc16.noarch
katello-certs-tools-1.1.8-1.fc16.noarch
katello-cli-common-1.1.1-1.fc16.noarch
katello-common-1.0.5-1.fc16.noarch


How reproducible:
yum install -y katello-all thumbslug
katello-configure --deployment=headpin

Steps to Reproduce:
1.Login to UI Server
2.Navigate Administer -> Users
3.Click to create + New User
4.Create a new user name similar to that of environment

Actual results:

A user is created successfully without throwing any error

Expected results:
A proper name validation should be provided to check whether
unique names are taken

Additional info:

screen shots attached
Comment 1 Eric Sammons 2012-08-17 13:01:22 EDT
Please confirm here, you are saying that you have created a user (newuser for example) and that you can then create an environment with the name newuser?

If this is the case then I believe this is not a bug as user and environments are separate entities within katello and therefore you could have a user dev and an environment dev.
Comment 2 Tazim Kolhar 2012-08-22 05:38:39 EDT
Hi,

    here, both user and environments have same name for example
    (newuser in the above case)
    but, it is clear now that these are separate entities, within 
    katello, this usecase should be allowed
    and hence not a bug.

Note You need to log in before you can comment on or make changes to this bug.