Bug 848770 - To subscribe another subscription failed after auto-subscribed a subscription
To subscribe another subscription failed after auto-subscribed a subscription
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-16 07:34 EDT by gaoshang
Modified: 2013-01-10 04:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 04:47:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2012-08-16 07:57:09 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 gaoshang 2012-08-17 01:53:22 EDT
I have also checked against the RHEL 5.9 Server with the same build, but the issue dose NOT happen.
Comment 3 gaoshang 2012-08-17 03:31:34 EDT
In rhsm.log I found following info, seems like it has the same root cause with bug https://bugzilla.redhat.com/show_bug.cgi?id=848742

2012-08-16 06:08:32,867 [INFO]  @certlib.py:220 - certs updated:
Total updates: 3
Found (local) serial# [-1]
Expected (UEP) serial# [897561339054440856L, 7497205689642099969L]
Added (new)
  [sn:-1 (Red Hat Enterprise Linux Desktop,) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Beta,) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Enterprise Linux Server,) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Enterprise Linux Resilient Storage (for RHEL Server),) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Enterprise Linux Scalable File System (for RHEL Server),) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Beta,) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Enterprise Linux Load Balancer (for RHEL Server),) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Enterprise Linux High Availability (for RHEL Server),) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Enterprise Linux Workstation,) @ /etc/pki/entitlement/-1.pem]
Deleted (rogue):
  [sn:-1 (Red Hat Enterprise Linux Desktop,) @ /etc/pki/entitlement/-1.pem]
  [sn:-1 (Red Hat Beta,) @ /etc/pki/entitlement/-1.pem]
Expired (deleted):
  <NONE>
Comment 4 Keqin Hong 2012-08-29 10:02:52 EDT
gaoshang,

Does this issue still exist after the fix of Bug 848742?
Comment 5 gaoshang 2012-08-30 06:34:37 EDT
(In reply to comment #4)
> gaoshang,
> 
> Does this issue still exist after the fix of Bug 848742?

Due to Bug 851124 - Unable to unsubscribe in GUI, can not check this issue for now.
Comment 6 gaoshang 2012-09-03 04:47:07 EDT
This bug got fixed indirectly after the Bug 848742 and 851124 got fixed in build 1.0.17:
subscription-manager-migration-1.0.17-1.el5
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-debuginfo-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
python-rhsm-1.0.6-1.el5

Note You need to log in before you can comment on or make changes to this bug.