Bug 848788 - Start virt-who service in BACKGROUND, the debug log should not be on terminal.
Start virt-who service in BACKGROUND, the debug log should not be on terminal.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Radek Novacek
Entitlement Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 08:16 EDT by Hui Wang
Modified: 2016-11-30 19:30 EST (History)
7 users (show)

See Also:
Fixed In Version: virt-who-0.7-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:35:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-08-16 08:16:05 EDT
Description of problem:
Start virt-who service, the debug log in terminal is confused

Version-Release number of selected component (if applicable):
virt-who-0.7-2.el5
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
python-rhsm-1.0.5-1.el5
katello-headpin-all-0.2.13-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch

How reproducible:

100%
Steps to Reproduce:
1. Register Host to SAM server
2. Edit virt-who config file on Host: 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
3. Start virt-who service
#service virt-who service
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@host1364 ~]# /usr/lib64/python2.4/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)
  
Actual results:
After start virt-who service, the log in the terminal should like:
#service virt-who service
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
Virt-who is running in libvirt mode
Starting infinite loop with 3600 seconds interval
Virtual machine found: 5.8_Server_x86_64: 15cbe67a-50b0-f62f-33c5-5e332622964a
Virtual machine found: test: d01d1b9f-6c30-ed74-f48b-dc1d126ae259
Sending list of uuids: ['15cbe67a-50b0-f62f-33c5-5e332622964a', 'd01d1b9f-6c30-ed74-f48b-dc1d126ae259']


Expected results:
After start virt-who service, the log in the terminal is:
#service virt-who service
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@host1364 ~]# /usr/lib64/python2.4/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: __init__
  category=DeprecationWarning)

Additional info:
Comment 1 RHEL Product and Program Management 2012-08-16 08:17:33 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Radek Novacek 2012-08-27 07:47:38 EDT
According to bug 808061, when running virt-who as a service with VIRTWHO_BACKGROUND=1, nothing should be printed on stdout/stderr. The log from virt-who is stored in /var/log/rhsm/rhsm.log. 

That warning about usage of deprecated function was fixed in virt-who-0.7-4.el5.

This is expected behavior, so I'll close the bug as NOTABUG.
Comment 3 Radek Novacek 2012-08-30 02:57:17 EDT
Reopening, need to verify if the deprecated warning is fixed
Comment 4 Hui Wang 2012-08-30 04:41:27 EDT
Verified.
When running virt-who service with VIRTWHO_BACKGROUND=1, there should be nothing on stdout/stderr

Version:

virt-who-0.7-4.el5
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
python-rhsm-1.0.5-1.el5
katello-headpin-all-0.2.13-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch

Step:
1. Register Host to SAM server
2. Edit virt-who config file on Host: 
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
3. Start virt-who service
[root@localhost ~]# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
[root@localhost ~]#
Comment 7 errata-xmlrpc 2013-01-08 02:35:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0072.html

Note You need to log in before you can comment on or make changes to this bug.