Bug 848820 - Editing of long lines in PXE grub and similar environments is difficult to impossible
Editing of long lines in PXE grub and similar environments is difficult to im...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vgabios (Show other bugs)
6.2
Unspecified Unspecified
low Severity low
: beta
: ---
Assigned To: Gerd Hoffmann
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 09:36 EDT by David Jaša
Modified: 2012-08-20 06:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 06:11:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen recording (1.70 MB, video/mp4)
2012-08-16 11:38 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-08-16 09:36:10 EDT
Description of problem:
Editing of long lines in PXE grub and similar environments is difficult to impossible

Version-Release number of selected component (if applicable):
seabios-0.6.1.2-19.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. edit very long kernel line in grub or pxe, use shortcuts like ctrl-w if possible
2.
3.
  
Actual results:
displayed text gets out of sync with what is actually is there

Expected results:
no such problems occur

Additional info:
see the screencast, note the weird things that happen with the cursor (arrow keys are only used for navigation in grub edit area)

given that I encountered this only in qemu VMs and in various versions of both gPXE in grub, I'm inclined to blame seabios. If it is not the case, please reassign
Comment 1 David Jaša 2012-08-16 11:38:01 EDT
Created attachment 604974 [details]
screen recording

screen recording via cellphone, once in grub edit, only arrows and backspace changed cursor position...
Comment 2 Gerd Hoffmann 2012-08-17 02:18:54 EDT
More likely a vgabios bug.

Nevertheless I can't reproduce it.  Editing in grub works just fine for me (RHEL-6 guest, i.e. grub1).  Pressing Ctrl-W has no effect at all.  Details please.
Comment 3 David Jaša 2012-08-17 04:59:43 EDT
(In reply to comment #2)
> More likely a vgabios bug.
> 
> Nevertheless I can't reproduce it.  Editing in grub works just fine for me
> (RHEL-6 guest, i.e. grub1).  Pressing Ctrl-W has no effect at all.  Details
> please.

I've sent you an email with instructions how to reproduce on my setup.
Comment 9 Gerd Hoffmann 2012-08-20 06:11:15 EDT
With the two attached binaries installed I see screen editing behavior becoming worse, on both virtual and real hardware.  So it is clearly pxelinux at fault here.

Running strings on the pxelinux binary says "PXELINUX 3.86 2010-04-01".  RHEL-6 ships 4.02 (this is what I'm running in my local setup).  I strongly recommend to update the pxelinux binaries on the boot server.

Note You need to log in before you can comment on or make changes to this bug.