Bug 848843 - Build vdsm hooks RPMs along with VDSM
Build vdsm hooks RPMs along with VDSM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vdsm (Show other bugs)
17
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Federico Simoncelli
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-16 10:51 EDT by Dan Yasny
Modified: 2013-07-02 03:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:51:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2012-08-16 10:51:30 EDT
Description of problem:
vdsm hooks need to be built as RPMs so they can be deployed with oVirt

currently, only these two are available:
vdsm-hook-faqemu.noarch : Fake qemu process for VDSM quality assurance
vdsm-hook-vhostmd.noarch : VDSM hook set for interaction with vhostmd

I would like to see all the currently available hooks in the repos

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Federico Simoncelli 2012-08-16 11:11:39 EDT
A patch has been proposed upstream:

commit bf4632e035aed250b7d625ea17d46d2f0df53e79
Author: Federico Simoncelli <fsimonce@redhat.com>
Date:   Thu Aug 16 10:57:01 2012 -0400

    BZ#848843 Enable vdsm hooks on fedora
    
    Change-Id: If2532336b956cb01fd4090fccefd325c3cf2e571
    Signed-off-by: Federico Simoncelli <fsimonce@redhat.com>

http://gerrit.ovirt.org/#/c/7266/
Comment 2 Federico Simoncelli 2013-02-21 03:51:49 EST
The hooks are now provided in fedora since vdsm-4.10.0-7.fc17.

Note You need to log in before you can comment on or make changes to this bug.