Red Hat Bugzilla – Bug 848961
perl rawhide update to 5.16.1-230.fc19 breaks dependencies not listed as broken by "rawhide report"
Last modified: 2012-08-17 04:54:53 EDT
Description of problem:
An attempt to run update which pulls perl-5.16.1-230.fc19 fails with:
Error: Package: perl-CGI-3.59-227.fc18.noarch (@rawhide/18)
Error: Package: perl-Version-Requirements-0.101022-227.fc18.noarch (@rawhide/18)
Error: Package: 3:perl-version-0.99-227.fc18.noarch (@rawhide/18)
Error: Package: perl-JSON-PP-2.27200-227.fc18.noarch (@rawhide/18)
Error: Package: perl-Perl-OSType-1.002-227.fc18.noarch (@rawhide/18)
All these require perl-5.16.0-227.fc18 and at least perl-version and perl-Version-Requirements prior to 5.16.1-230.fc19 were subpackages of perl.rpm and AFAICT are not made now "obsolete". None of the above is listed in "Broken deps" of rawhide report.
Moreover an attempt to remove packages in question tries to remove quite a list of further packages due to dependencies and not even all of them "perl-..."; like for example gnucash still present in rawhide repositories.
Version-Release number of selected component (if applicable):
Marcela tried removing dual-lived sub-packages of perl.spec. It turned out there are some hard-coded dependencies on exact perl binary package and that some sub-packages have newer release than standalone ones what prevents yum from picking the right packages. She has fixed some of them, but not obviously all of them.
We will fix it soon.
This has been fixed by:
I found Marcela has not removed all dual-living sub-packages. We will remove them later. Properly, without breaking perl update path.