Bug 848961 - perl rawhide update to 5.16.1-230.fc19 breaks dependencies not listed as broken by "rawhide report"
perl rawhide update to 5.16.1-230.fc19 breaks dependencies not listed as brok...
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-08-16 19:27 EDT by Michal Jaegermann
Modified: 2012-08-17 04:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-17 04:54:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-08-16 19:27:03 EDT
Description of problem:

An attempt to run update which pulls perl-5.16.1-230.fc19 fails with:

Error: Package: perl-CGI-3.59-227.fc18.noarch (@rawhide/18)
Error: Package: perl-Version-Requirements-0.101022-227.fc18.noarch (@rawhide/18)
Error: Package: 3:perl-version-0.99-227.fc18.noarch (@rawhide/18)
Error: Package: perl-JSON-PP-2.27200-227.fc18.noarch (@rawhide/18)
Error: Package: perl-Perl-OSType-1.002-227.fc18.noarch (@rawhide/18)

All these require perl-5.16.0-227.fc18 and at least perl-version and perl-Version-Requirements prior to 5.16.1-230.fc19 were subpackages of perl.rpm and AFAICT are not made now "obsolete". None of the above is listed in "Broken deps" of rawhide report.

Moreover an attempt to remove packages in question tries to remove quite a list of further packages due to dependencies and not even all of them "perl-..."; like for example gnucash still present in rawhide repositories.

What gives?

Version-Release number of selected component (if applicable):
Comment 1 Petr Pisar 2012-08-17 02:50:14 EDT
Marcela tried removing dual-lived sub-packages of perl.spec. It turned out there are some hard-coded dependencies on exact perl binary package and that some sub-packages have newer release than standalone ones what prevents yum from picking the right packages. She has fixed some of them, but not obviously all of them.

We will fix it soon.
Comment 2 Petr Pisar 2012-08-17 04:54:53 EDT
This has been fixed by:


I found Marcela has not removed all dual-living sub-packages. We will remove them later. Properly, without breaking perl update path.

Note You need to log in before you can comment on or make changes to this bug.