Bug 849004 - [glusterfs-3.1.3qa8]: fd leak in glusterfs server
[glusterfs-3.1.3qa8]: fd leak in glusterfs server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rdma (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Raghavendra G
shylesh
:
Depends On: 764256
Blocks: 858446
  Show dependency treegraph
 
Reported: 2012-08-16 23:37 EDT by Vidya Sakar
Modified: 2015-02-13 04:45 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 764256
: 858446 (view as bug list)
Environment:
Last Closed: 2015-02-13 04:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-16 23:37:39 EDT
+++ This bug was initially created as a clone of Bug #764256 +++

there seems to be an fd leak in the glusterfs server when setup in the rdma mode.

This is the contents of /proc/<server pid>/fd



lrwx------ 1 root root 64 Mar 14 05:59 6 -> socket:[86213]
lrwx------ 1 root root 64 Mar 14 05:59 60 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quiesce/src/quiesce-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 61 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/read-only/src/read-only.c
lrwx------ 1 root root 64 Mar 14 05:59 62 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 63 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 64 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/src/quota-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 65 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/src/quota.c
lrwx------ 1 root root 64 Mar 14 05:59 66 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/read-only/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 67 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/read-only/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 68 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/trash.c
lrwx------ 1 root root 64 Mar 14 05:59 69 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 7 -> socket:[86262]
lrwx------ 1 root root 64 Mar 14 05:59 70 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 71 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/lib/src/libxlator.h
lrwx------ 1 root root 64 Mar 14 05:59 72 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/trash-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 73 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/lib/src/libxlator.c
lrwx------ 1 root root 64 Mar 14 05:59 74 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/trash.h
lrwx------ 1 root root 64 Mar 14 05:59 75 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/meta-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 76 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 77 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 78 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/meta.c
lrwx------ 1 root root 64 Mar 14 05:59 79 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/meta.h
lrwx------ 1 root root 64 Mar 14 05:59 8 -> /tmp/tmpfKi10zm (deleted)
lrwx------ 1 root root 64 Mar 14 05:59 80 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/misc.c
lrwx------ 1 root root 64 Mar 14 05:59 81 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/misc.h
lrwx------ 1 root root 64 Mar 14 05:59 82 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/tree.c
lrwx------ 1 root root 64 Mar 14 05:59 83 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/tree.h
lrwx------ 1 root root 64 Mar 14 05:59 84 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-handler.c
lrwx------ 1 root root 64 Mar 14 05:59 85 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/view.c
lrwx------ 1 root root 64 Mar 14 05:59 86 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 87 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/view.h
lrwx------ 1 root root 64 Mar 14 05:59 88 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 89 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 9 -> /dev/infiniband/uverbs0
lrwx------ 1 root root 64 Mar 14 05:59 90 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-hand


This is the leak on the other machine (it was a replicate setup).


lrwx------ 1 root root 64 Mar 14 05:59 6 -> socket:[6174868]
lrwx------ 1 root root 64 Mar 14 05:59 60 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 61 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 62 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/src/quota-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 63 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/quota/src/quota.c
lrwx------ 1 root root 64 Mar 14 05:59 64 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/read-only/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 65 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/read-only/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 66 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/trash.c
lrwx------ 1 root root 64 Mar 14 05:59 67 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 68 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 69 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/lib/src/libxlator.h
lrwx------ 1 root root 64 Mar 14 05:59 7 -> socket:[6174918]
lrwx------ 1 root root 64 Mar 14 05:59 70 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/trash-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 71 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/lib/src/libxlator.c
lrwx------ 1 root root 64 Mar 14 05:59 72 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/features/trash/src/trash.h
lrwx------ 1 root root 64 Mar 14 05:59 73 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/meta-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 74 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 75 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 76 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/meta.c
lrwx------ 1 root root 64 Mar 14 05:59 77 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/meta.h
lrwx------ 1 root root 64 Mar 14 05:59 78 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/misc.c
lrwx------ 1 root root 64 Mar 14 05:59 79 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/misc.h
lrwx------ 1 root root 64 Mar 14 05:59 8 -> /tmp/tmpfEyyqnW (deleted)
lrwx------ 1 root root 64 Mar 14 05:59 80 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/tree.c
lrwx------ 1 root root 64 Mar 14 05:59 81 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/tree.h
lrwx------ 1 root root 64 Mar 14 05:59 82 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-handshake.c
lrwx------ 1 root root 64 Mar 14 05:59 83 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/view.c
lrwx------ 1 root root 64 Mar 14 05:59 84 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 85 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/meta/src/view.h
lrwx------ 1 root root 64 Mar 14 05:59 86 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 87 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/Makefile.am
lrwx------ 1 root root 64 Mar 14 05:59 88 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-pmap.c
lrwx------ 1 root root 64 Mar 14 05:59 89 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-handler.c
lrwx------ 1 root root 64 Mar 14 05:59 9 -> /dev/infiniband/uverbs0
lrwx------ 1 root root 64 Mar 14 05:59 90 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-pmap.h
lrwx------ 1 root root 64 Mar 14 05:59 91 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-mem-types.h
lrwx------ 1 root root 64 Mar 14 05:59 92 -> /data/export/rdma/n/run6846/glusterfs.git/xlators/mgmt/glusterd/src/glusterd-
Comment 2 Amar Tumballi 2012-08-23 02:44:59 EDT
This bug is not seen in current master branch (which will get branched as RHS 2.1.0 soon). To consider it for fixing, want to make sure this bug still exists in RHS servers. If not reproduced, would like to close this.
Comment 4 Sachidananda Urs 2013-08-08 01:43:14 EDT
Moving out of Big Bend since RDMA support is not available in Big Bend,2.1

Note You need to log in before you can comment on or make changes to this bug.