Bug 849022 - Error message appears in terminal when open subscription-manager gui from terminal if the system not registered
Error message appears in terminal when open subscription-manager gui from ter...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: QA-Closed
: 848027 (view as bug list)
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-17 01:44 EDT by xingge
Modified: 2016-09-19 22:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log when error happened (6.01 KB, text/x-log)
2012-08-17 02:54 EDT, xingge
no flags Details

  None (edit)
Description xingge 2012-08-17 01:44:17 EDT
Description of problem:
Error message appears in the terminal when open subscription-manager gui from the terminal by running command 'subscription-manager-gui' if the system is not registered.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
python-rhsm-1.0.5-1.el5

How reproducible:
always

Steps to Reproduce:
1.Make sure the system is not registered
2.open subscription-manager gui from terminal by:
#subscription-manager-gui
  
Actual results:
The subscription-manager-gui opens, and below errror message will show in terminal:
Error while checking server version: No such file or directory 

Expected results:
The subscription-manager-gui will open and no error appear in the terminal

Additional info:
1. Once the system registered then re-open the subscription-manager-gui as step 2 the error message will not appear
2. If register the system after above step 2, and then run the version command as below:
#subscription-manager version

then get this output - pls be noticed it shows 'Unknown' for the 'remote entitlement server' info:
remote entitlement server: Unknown
remote entitlement server type: subscription management service
subscription-manager: 1.0.13-1.el5
python-rhsm: 1.0.5-1.el5
Comment 1 RHEL Product and Program Management 2012-08-17 01:56:57 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 xingge 2012-08-17 02:54:11 EDT
Created attachment 605093 [details]
log when error happened
Comment 3 Bryan Kearney 2012-08-17 12:26:34 EDT
I can not re-create, and there has been lots of work around version checking. Please re-verify with veriosn 1.0.14 or greater.
Comment 5 Bryan Kearney 2012-08-17 12:49:52 EDT
*** Bug 848027 has been marked as a duplicate of this bug. ***
Comment 7 spandey 2012-08-23 12:04:01 EDT
verified using following rpm 

subscription-manager-gui-1.0.14-1.git.20.7e3f72a.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-firstboot-1.0.14-1.git.20.7e3f72a.el5
subscription-manager-migration-1.0.14-1.git.20.7e3f72a.el5
subscription-manager-1.0.14-1.git.20.7e3f72a.el5

Now version error is not getting displayed , working fine 
after register i got following message with version command 


[root@localhost ~]# subscription-manager version
registered to: 0.7.6-1
server type: subscription management service
subscription-manager: 1.0.14-1.git.20.7e3f72a.el5
python-rhsm: 1.0.5-1.git.1.1ce0910.el5


Working fine resolving defect as verified.
Comment 9 errata-xmlrpc 2013-01-07 22:59:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.