Bug 849024 - Can't add a Jenkins client to an application after creating Jenkins server
Can't add a Jenkins client to an application after creating Jenkins server
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 01:52 EDT by Wei Sun
Modified: 2015-05-14 18:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: devenv_2013
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:28:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2012-08-17 01:52:48 EDT
Description of problem:
Can't add a jenkins client to an application after creating Jenkins server,and will return error message

Version-Release number of selected component (if applicable):
devenv_2009
INT
rhc (0.97.11)
How reproducible:

always
Steps to Reproduce:
1.create a Jenkins server
2.create an application
3.add a jenkins client to the application
  
Actual results:

Contacting https://int.openshift.redhat.com
Problem reported from server. Response code was 500.

DEBUG:
/usr/bin/wget: option requires an argument -- 'O'
Usage: wget [OPTION]... [URL]...

Try ‘wget --help’ for more options.
/usr/libexec/stickshift/cartridges/embedded/jenkins-client-1.4/info/hooks/configure: line 71: /var/lib/stickshift/6bd9a2dc3a2f420d801efa887cc3fed5//jenkins-client-1.4/jenkins-cli.jar: No such file or directory
/usr/bin/wget: option requires an argument -- 'O'
Usage: wget [OPTION]... [URL]...

Try ‘wget --help’ for more options.
/usr/libexec/stickshift/cartridges/embedded/jenkins-client-1.4/info/hooks/configure: line 71: /var/lib/stickshift/6bd9a2dc3a2f420d801efa887cc3fed5//jenkins-client-1.4/jenkins-cli.jar: No such file or directory
Cartridge return code: 157

Exit Code: 143
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version: 1.1.3

RESULT:
Error contacting Jenkins server.
Could not download https://jenkinsdsw1s-2g9cumv1rj.int.rhcloud.com/jnlpJars/jenkins-cli.jar
Expected results:
Add jenkins client successfully

Additional info:
Comment 1 Xiaoli Tian 2012-08-17 02:08:54 EDT
Work around on devenv:

Just need to modify /usr/libexec/stickshift/cartridges/embedded/jenkins-client-1.4/info/hooks/configure +71  from:
/usr/bin/wget --no-check-certificate -q https://${JENKINS_USERNAME}:${JENKINS_PASSWORD}@${JENKINS_DNS_NAME}jnlpJars/jenkins-cli.jar -O
"$OPENSHIFT_HOMEDIR/jenkins-client-1.4/jenkins-cli.jar"

to

/usr/bin/wget --no-check-certificate -q https://${JENKINS_USERNAME}:${JENKINS_PASSWORD}@${JENKINS_DNS_NAME}jnlpJars/jenkins-cli.jar -O "$OPENSHIFT_HOMEDIR/jenkins-client-1.4/jenkins-cli.jar"

And restart libra-broker, then it works.
Comment 2 Jhon Honce 2012-08-17 11:57:03 EDT

*** This bug has been marked as a duplicate of bug 823720 ***
Comment 3 Xiaoli Tian 2012-08-17 21:48:41 EDT
This is not a duplicate bug of bug 823720, this bug is a regression caused by the fix for bug 823720.
Comment 4 Wei Sun 2012-08-19 23:06:36 EDT
verified on devenv_2029

1.create a Jenkins server
2.create an application
3.add a jenkins client to the application

Result:
[sunwei@dhcp-8-229 dev]$ rhc app cartridge add -a php1 -c jenkins-client-1.4 -d -p x
Contacting https://ec2-23-22-147-56.compute-1.amazonaws.com
Response from server:
DEBUG:
Embedded app details: Job URL: https://jenkins-wsundev820.dev.rhcloud.com/job/php1-build/

Exit Code: 0
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version:    1.1.3

RESULT:

Associated with job 'php1-build' in Jenkins server.

Job URL: https://jenkins-wsundev820.dev.rhcloud.com/job/php1-build/

Jenkins client 1.4 has been added to: php1

Note You need to log in before you can comment on or make changes to this bug.