Bug 849056 - Button 'configure' in network setting spoke doesn't work.
Button 'configure' in network setting spoke doesn't work.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
: 849359 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 04:01 EDT by Petr Schindler
Modified: 2012-08-28 04:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: lorax-18.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 04:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (173.84 KB, text/plain)
2012-08-17 04:01 EDT, Petr Schindler
no flags Details
proposed patch to get nm-connection-editor back in (1.79 KB, text/plain)
2012-08-20 04:37 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Petr Schindler 2012-08-17 04:01:04 EDT
Created attachment 605114 [details]
traceback

Description of problem:
A window with title 'an unknown error has occured' shows up when I click on 'configure' button in the network setting spoke. Anaconda is unusable then.

Version-Release number of selected component (if applicable):
anaconda-18.6
Alpha-TC3-DVD.iso

How reproducible:
always

Steps to Reproduce:
1. Run anaconda
2. go to network configuration spoke
3. click on the 'configure' button
  
Actual results:
exception is raised

Expected results:
window with network configuration should occure

Additional info:
Traceback from log:

anaconda 18.6 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception
  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 430, in on_edit_connection
    subprocess.Popen(["nm-connection-editor", "--edit", "%s" % uuid])
OSError: [Errno 2] No such file or directory
Comment 1 Radek Vykydal 2012-08-20 04:37:55 EDT
Created attachment 605603 [details]
proposed patch to get nm-connection-editor back in
Comment 2 Radek Vykydal 2012-08-20 04:50:03 EDT
*** Bug 849359 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-08-23 18:19:46 EDT
lorax-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.15-1.fc18
Comment 4 Fedora Update System 2012-08-23 21:24:22 EDT
Package lorax-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12621/lorax-18.15-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-08-28 04:05:09 EDT
lorax-18.15-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.