Bug 849078 - Get error messages in threaddump info of ruby-1.8 and ruby-1.9 apps
Get error messages in threaddump info of ruby-1.8 and ruby-1.9 apps
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 05:00 EDT by jizhao
Modified: 2015-05-14 22:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 05:55:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-08-17 05:00:29 EDT
Description of problem:
Create a ruby-1.8/ruby-1.9 app and do threaddump. Get errors in the threaddump info.

Version-Release number of selected component (if applicable):
rhc-0.97.11-1.el6_3.noarch
devenv_2011

How reproducible:
Always

Steps to Reproduce:
1.Create a ruby-1.8/ruby-1.9 app
2.Do threaddump
$ rhc app threaddump -a <appname>
3.Tail the log
$ rhc app tail -a <appname> -f <appname>/logs/error_log-20120817-000000-EST
  
Actual results:
For ruby-1.8 app:
<------------------output------------------->
[ pid=10888 thr=70000762503600 file=abstract_request_handler.rb:445 time=2012-08-17 04:27:29.783 ]: ========== Process 10888: backtrace dump ==========
------------------------------------------------------------
# Current thread: #<Thread:0x7f54a52a8360 run>
------------------------------------------------------------
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_request_handler.rb:445:in `install_useful_signal_handlers'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_request_handler.rb:456:in `call'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_request_handler.rb:456:in `select'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_request_handler.rb:456:in `accept_and_process_next_request'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/rack/application_spawner.rb:205:in `start_request_handler'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/rack/application_spawner.rb:78:in `spawn_application'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/utils.rb:479:in `safe_fork'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/rack/application_spawner.rb:63:in `spawn_application'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/spawn_manager.rb:264:in `spawn_rack_application'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/spawn_manager.rb:137:in `spawn_application'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_server.rb:357:in `__send__'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
    /usr/lib/ruby/gems/1.8/gems/passenger-3.0.4/helper-scripts/passenger-spawn-server:102
<------------------------------------------>

For ruby-1.9 app:
<---------------------output-------------->
[ pid=32237 thr=7788660 file=abstract_request_handler.rb:445 time=2012-08-17 04:50:07.577 ]: ========== Process 32237: backtrace dump ==========
------------------------------------------------------------
# Current thread: #<Thread:0x00000000edb0e8 run>
------------------------------------------------------------
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_request_handler.rb:445:in `block in install_useful_signal_handlers'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_request_handler.rb:456:in `call'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_request_handler.rb:456:in `select'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_request_handler.rb:456:in `accept_and_process_next_request'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/rack/application_spawner.rb:206:in `start_request_handler'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/rack/application_spawner.rb:79:in `block in spawn_application'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/utils.rb:479:in `safe_fork'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/rack/application_spawner.rb:64:in `spawn_application'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/spawn_manager.rb:264:in `spawn_rack_application'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/spawn_manager.rb:137:in `spawn_application'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
    /opt/rh/ruby193/root/usr/share/gems/gems/passenger-3.0.12/helper-scripts/passenger-spawn-server:102:in `<main>'
<--------------------------------------------->

Expected results:
There shouldn't be any error.

Additional info:
Comment 1 jizhao 2012-08-17 05:55:10 EDT
This should be the expected results of ruby threaddump. Close it as not a bug.

Note You need to log in before you can comment on or make changes to this bug.