Bug 849105 - Spelling mistake happens to output when execute subscription-manager environments
Spelling mistake happens to output when execute subscription-manager environm...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-17 06:33 EDT by Fengshuang Tan
Modified: 2013-01-10 04:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fengshuang Tan 2012-08-17 06:33:37 EDT
Description of problem:
when execute subscription-manager environments,there is a spelling mistake.
"organizaiton" ==> It should be "organization"

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
python-rhsm-1.0.5-1.el5

How reproducible:
always

Steps to Reproduce:
1.register system to stage candlepin:
  subscription-manager register

2.execute command:
  subscription-manager environments
  
Actual results:
error message is shown as follows:
"Error: This command requires that you specify an organizaiton with --org."

Expected results:
exact message should be:
"Error: This command requires that you specify an organization with --org."

Additional info:
this bug can be reproduced on RHEL 5.9 Server i386, RHEL 5.9 Server x86_64, RHEL 5.9 Client i386 and RHEL 5.9 Client x86_64.
Comment 1 RHEL Product and Program Management 2012-08-17 06:37:03 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-08-17 12:31:20 EDT
fixed in master at b74cd1ba6666c1189dace753a92fe8b5ad9c69cd.
Comment 5 J.C. Molet 2012-08-22 11:17:19 EDT
Testing with latest in brew: 
subscription-manager-1.0.14-1.el5
subscription-manager-migration-1.0.14-1.el5
python-rhsm-1.0.5-1.el5
subscription-manager-migration-data-1.11.2.3-1.el5



[root@jmolet-vm0 brew]# subscription-manager register --username testuser1 --password password --org admin
The system has been registered with id: aabdf1c9-9e21-4b25-9a2b-af9d09fc20fd 

[root@jmolet-vm0 brew]# subscription-manager environments
Error: This command requires that you specify an organization with --org


organization is now speeled correctly.
Comment 7 errata-xmlrpc 2013-01-07 22:59:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.