Bug 849171 - getting an extraneous "verify\n" in stdout during an invalid certificate import
getting an extraneous "verify\n" in stdout during an invalid certificate import
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Regression
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-17 10:59 EDT by John Sefler
Modified: 2013-01-10 04:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-17 10:59:08 EDT
Description of problem:
An extraneous "verify\n" prefix seems to have snuck into a stdout message when attempting to import an invalid certificate.

Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# subscription-manager version
registered to: 0.7.6-1
server type: subscription management service
subscription-manager: 1.0.13-1.git.45.5cb55c8.el5
python-rhsm: 1.0.5-1.git.1.1ce0910.el5


How reproducible:
sometimes

Steps to Reproduce:
[root@jsefler-rhel59 ~]# subscription-manager import --certificate /etc/pki/entitlement/969118734171102355-key.pem 
verify
969118734171102355-key.pem is not a valid certificate file. Please use a valid certificate.
[root@jsefler-rhel59 ~]# 


Actual Results:
verify               <============ UNEXPECTED
969118734171102355-key.pem is not a valid certificate file. Please use a valid certificate.

Expected Results:
969118734171102355-key.pem is not a valid certificate file. Please use a valid certificate.

Additional info:
Comment 2 Bryan Kearney 2012-08-17 12:47:17 EDT
fixed in master at 18c5fde261c4b1da1fd8e0cdb0966f2357dbb67a
Comment 4 John Sefler 2012-08-24 17:25:02 EDT
Verifying Version....

[root@jsefler-rhel59 ~]# subscription-manager version
registered to: Unknown
server type: subscription management service
subscription-manager: 1.0.14-1.el5

[root@jsefler-rhel59 ~]# subscription-manager import --certificate /etc/pki/entitlement/5757936486111047833.pem 
5757936486111047833.pem is not a valid certificate file. Please use a valid certificate.
[root@jsefler-rhel59 ~]# 
[root@jsefler-rhel59 ~]# subscription-manager import --certificate /etc/pki/entitlement/5757936486111047833-key.pem 
5757936486111047833-key.pem is not a valid certificate file. Please use a valid certificate.
[root@jsefler-rhel59 ~]# 
[root@jsefler-rhel59 ~]# subscription-manager import --certificate /etc/pki/consumer/cert.pem 
cert.pem is not a valid certificate file. Please use a valid certificate.
[root@jsefler-rhel59 ~]# 
[root@jsefler-rhel59 ~]# subscription-manager import --certificate /etc/pki/consumer/key.pem 
key.pem is not a valid certificate file. Please use a valid certificate.
[root@jsefler-rhel59 ~]# 

^^^ VERIFIED: The extraneous "verify" string was not printed during any of the negative certificate import tests above.
Comment 6 errata-xmlrpc 2013-01-07 22:59:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.