Bug 849274 - bad maps in RHEL5 channel-cert-mapping.txt for jboss products
bad maps in RHEL5 channel-cert-mapping.txt for jboss products
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-17 19:14 EDT by John Sefler
Modified: 2013-01-08 02:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:28:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-17 19:14:31 EDT
Description of problem:
I have an automated test that is telling me:

201208171803:32.184 - WARNING: Existing productCert file '/usr/share/rhsm/product/RHEL-5/Server-JBEAP-i386-ab0700cf21f0-183.pem' is NOT mapped in '/usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt'.
201208171803:32.185 - WARNING: Existing productCert file '/usr/share/rhsm/product/RHEL-5/Server-JBEAP-x86_64-315a472635ba-183.pem' is NOT mapped in '/usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt'.



Using the product-baseline.json as our bible...
[rcm/rcm-metadata.git] / cdn / product-baseline.json
         "Name": "JBoss Enterprise Application Platform", 
         "Product ID": "183", 
         "RHN Channels": [
             "jbappplatform-4.3.0-i386-server-5-rpm", 
             "jbappplatform-4.3.0-x86_64-server-5-rpm", 
             "jbappplatform-5-i386-server-5-rpm", 
             "jbappplatform-5-i386-server-6-rpm", 
             "jbappplatform-5-x86_64-server-5-rpm", 
             "jbappplatform-5-x86_64-server-6-rpm", 
             "jbappplatform-6-i386-server-6-rpm", 
             "jbappplatform-6-x86_64-server-6-rpm"
         ]
... we see that a RHEL5 mapping is needed for:
jbappplatform-4.3.0-i386-server-5-rpm
jbappplatform-4.3.0-x86_64-server-5-rpm

... and probing the content of [rcm/rcm-metadata.git] / product_ids / jboss / we find that 
Server-JBEAP-i386-ab0700cf21f0-183.pem  maps to jbappplatform-4.3.0-i386-server-5-rpm
Server-JBEAP-x86_64-315a472635ba-183.pem  maps to jbappplatform-4.3.0-x86_64-server-5-rpm


Therefore channel-cert-mapping.txt needs the following two lines:
jbappplatform-4.3.0-i386-server-5-rpm: Server-JBEAP-i386-ab0700cf21f0-183.pem
jbappplatform-4.3.0-x86_64-server-5-rpm: Server-JBEAP-x86_64-315a472635ba-183.pem



Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 ~]# grep -- -183.pem /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt

Actual results:
jbappplatform-4.3.0-i386-server-5-rpm: Server-JBEAP-i386-5696030298b2-183.pem <==== WRONG
jbappplatform-4.3.0-x86_64-server-5-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem <==== WRONG
jbappplatform-5-i386-server-5-rpm: Server-JBEAP-i386-5696030298b2-183.pem
jbappplatform-5-i386-server-6-rpm: Server-JBEAP-i386-5696030298b2-183.pem <==== NOT-RHEL5
jbappplatform-5-x86_64-server-5-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem
jbappplatform-5-x86_64-server-6-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem <==== NOT-RHEL5
jbappplatform-6-i386-server-6-rpm: Server-JBEAP-i386-5696030298b2-183.pem <==== NOT-RHEL5
jbappplatform-6-x86_64-server-6-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem <==== NOT-RHEL5


Expected results:
jbappplatform-4.3.0-i386-server-5-rpm: Server-JBEAP-i386-ab0700cf21f0-183.pem
jbappplatform-4.3.0-x86_64-server-5-rpm: Server-JBEAP-x86_64-315a472635ba-183.pem
jbappplatform-5-i386-server-5-rpm: Server-JBEAP-i386-5696030298b2-183.pem
jbappplatform-5-x86_64-server-5-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem



Additional info:
Comment 1 RHEL Product and Program Management 2012-08-17 19:18:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Alex Wood 2012-08-23 12:53:44 EDT
commit 8bd27beb81aa4eff4fb76a9d5b4613164a16785a
Refs: RHEL5.9, <origin/RHEL5.9>, subscription-manager-migration-data-1.11.2.3-1~
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Thu Aug 23 11:15:38 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Thu Aug 23 12:50:38 2012 -0400

    849274, 849305: Update mappings for JBEAP and RHEV Agent.

Available in subscription-manager-migration-data-1.11.2.4-1+
Comment 4 John Sefler 2012-09-07 17:37:32 EDT
Verifying Version...
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.4-1.el5


[root@rhsm-accept-rhel5 ~]# rpm -ql subscription-manager-migration-data | grep 183.pem
/usr/share/rhsm/product/RHEL-5/Server-JBEAP-i386-5696030298b2-183.pem
/usr/share/rhsm/product/RHEL-5/Server-JBEAP-i386-998220271ded-183.pem
/usr/share/rhsm/product/RHEL-5/Server-JBEAP-i386-ab0700cf21f0-183.pem
/usr/share/rhsm/product/RHEL-5/Server-JBEAP-x86_64-315a472635ba-183.pem
/usr/share/rhsm/product/RHEL-5/Server-JBEAP-x86_64-84e3f0269178-183.pem
/usr/share/rhsm/product/RHEL-5/Server-JBEAP-x86_64-d9384bbbf3ee-183.pem


[root@rhsm-accept-rhel5 ~]# grep -- -183.pem /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
jbappplatform-4.3.0-i386-server-5-rpm: Server-JBEAP-i386-ab0700cf21f0-183.pem
jbappplatform-4.3.0-x86_64-server-5-rpm: Server-JBEAP-x86_64-315a472635ba-183.pem
jbappplatform-5-i386-server-5-rpm: Server-JBEAP-i386-5696030298b2-183.pem
jbappplatform-5-i386-server-6-rpm: Server-JBEAP-i386-5696030298b2-183.pem
jbappplatform-5-x86_64-server-5-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem
jbappplatform-5-x86_64-server-6-rpm: Server-JBEAP-x86_64-84e3f0269178-183.pem
jbappplatform-6-i386-server-6-rpm: Server-JBEAP-i386-998220271ded-183.pem
jbappplatform-6-x86_64-server-6-rpm: Server-JBEAP-x86_64-d9384bbbf3ee-183.pem


^^^ VERIFIED: JBoss Enterprise Application Platform product ids (183) for all of its versions (4.3,5,6) are present and mapped in the subscription-manager data for the rhel5 server channels.  Note that the four extra rhel6 server channel mappings are here too (this is harmless and will never be used on a rhel5 system).
Comment 6 errata-xmlrpc 2013-01-08 02:28:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0055.html

Note You need to log in before you can comment on or make changes to this bug.