Bug 849376 - Python and associated components can't be installed or upgraded
Python and associated components can't be installed or upgraded
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-18 19:01 EDT by rasta
Modified: 2012-08-19 04:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-19 04:50:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rasta 2012-08-18 19:01:33 EDT
Description of problem: I first encountered the problem trying to install scipy. However the same behaviour occurs when trying to install any python-related component (including upgrading Python itself.)

Thus if I do: yum install scipy
          or: yum update python-2.7.3-7.2.fc17

I get:
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package python.i686 0:2.7.3-6.fc17 will be updated
---> Package python.i686 0:2.7.3-7.2.fc17 will be an update
--> Processing Dependency: python-libs(x86-32) = 2.7.3-7.2.fc17 for package: python-2.7.3-7.2.fc17.i686
--> Running transaction check
---> Package python-libs.i686 0:2.7.3-6.fc17 will be updated
---> Package python-libs.i686 0:2.7.3-7.2.fc17 will be an update
ftp://ftp.sucs.org/pub/linux/fedora/updates/17/i386/repodata/819390cda0dc34f3c7b801d103b921bd0cf2a459f82a5fa1ff48fce7038ccd00-filelists.sqlite.bz2: [Errno 14] FTP Error 550 : ftp://ftp.sucs.org/pub/linux/fedora/updates/17/i386/repodata/819390cda0dc34f3c7b801d103b921bd0cf2a459f82a5fa1ff48fce7038ccd00-filelists.sqlite.bz2 
Trying other mirror.
updates/filelists_db                                     | 8.3 MB     00:00     
--> Processing Dependency: /bin/python2.7 for package: PIL-1.1.7-10.fc17.i686
--> Finished Dependency Resolution
Error: Package: PIL-1.1.7-10.fc17.i686 (@atrpms)
           Requires: /bin/python2.7
           Removing: python-2.7.3-6.fc17.i686 (@anaconda-0)
               Not found
           Updated By: python-2.7.3-7.2.fc17.i686 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Following further examination I removed altogether, by deleting from the yum.repos.d, the atrpms repo, but the problem persists.

A note on the following site: http://www.gossamer-threads.com/lists/atrpms/devel/16269

suggests rebuilding PIL from source, but an attempted rebuild only failed:

Installing PIL-1.1.7-10.src.rpm
error: line 13: Dependency tokens must begin with alpha-numeric, '_' or '/': Requires: %{python_libdir}

after yum-builddep PIL-1.1.7-10.src.rpm also failed with the same message as any other for installing a Python component.

Thus at this point no Python component can be installed or updated.

Version-Release number of selected component (if applicable): python-2.7.3-7.2.fc17.i686 (currently using python-2.7.3-6.fc17.i686)


How reproducible: Have Fedora 17 with python-2.7.3-6.fc17.i686 installed. Attempt to install or update any Python component.


Steps to Reproduce:
1. yum update python-2.7.3-7.2.fc17
2.
3.
  
Actual results: 
Error: Package: PIL-1.1.7-10.fc17.i686 (@atrpms)
           Requires: /bin/python2.7
           Removing: python-2.7.3-6.fc17.i686 (@anaconda-0)
               Not found
           Updated By: python-2.7.3-7.2.fc17.i686 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results: Python updated, or additional python component (such as scipy) installed.


Additional info:
Comment 1 Thomas Spura 2012-08-19 04:50:25 EDT
(In reply to comment #0)
> Following further examination I removed altogether, by deleting from the
> yum.repos.d, the atrpms repo, but the problem persists.

Just removing the repo doesn't help. You also need to remove all packages from atrpms in order to stick with the packages in the fedora repo.

> suggests rebuilding PIL from source, but an attempted rebuild only failed:
> 
> Installing PIL-1.1.7-10.src.rpm
> error: line 13: Dependency tokens must begin with alpha-numeric, '_' or '/':
> Requires: %{python_libdir}

You talk about rebuilding, but you are installing a src.rpm?
To rebuilt it, you could try "rpmbuild --rebuild PIL-1.1.7-10.src.rpm".

> Actual results: 
> Error: Package: PIL-1.1.7-10.fc17.i686 (@atrpms)
>            Requires: /bin/python2.7
>            Removing: python-2.7.3-6.fc17.i686 (@anaconda-0)
>                Not found
>            Updated By: python-2.7.3-7.2.fc17.i686 (updates)
>                Not found
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> 
> Expected results: Python updated, or additional python component (such as
> scipy) installed.

So all in all. This is a problem of atrpms, because it requires /bin/python2.7 (which looks strange, as it should be /usr/bin/python2.7).

We cannot do anything about the packages from atrpms. Please report this bug over there.

Closing as cantfix.

Note You need to log in before you can comment on or make changes to this bug.