Bug 849396 - RESTAPI: Template resource has link to non existent /tags sub-collection
RESTAPI: Template resource has link to non existent /tags sub-collection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ori Liel
Jakub Libosvar
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 02:30 EDT by Michael Pasternak
Modified: 2016-02-10 14:16 EST (History)
12 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Pasternak 2012-08-19 02:30:20 EDT
Description of problem:

RESTAPI: Template resource has link to non existent /tags sub-collection
Comment 1 Anand Nande 2012-08-19 03:14:06 EDT
Same is true with non-existent: Snapshots and Statistics sub-collections.
Comment 2 Itamar Heim 2012-08-19 08:08:54 EDT
(In reply to comment #1)
> Same is true with non-existent: Snapshots and Statistics sub-collections.

template shouldn't have snapshots?
Comment 3 Michael Pasternak 2012-08-20 02:34:30 EDT
yes, because all snapshots are merged during template creation.
Comment 7 Ori Liel 2012-08-26 09:12:26 EDT
More info - 

Error only for single template: 
  
  GET .../api/templates/xxx

(Redundant links don't appear for collection level): 
  
  GET .../api/templates
Comment 8 Ori Liel 2012-08-26 09:45:24 EDT
patch posted: 

http://gerrit.ovirt.org/#/c/7471/
Comment 9 Simon Grinberg 2012-08-27 05:34:29 EDT
Just to be clear: we remain for the time being with: "disks", "nics", "cdroms", "permissions" which are the only valid sub-collections for templates.

If a customer requests other sub-collections then please open an RFE for that and attach the ticket there. 

Anand, your RFE sounds as a Valid one
Roman, Please inform your customers that snapshots are irrelevant for Template, same as run time statistics. The existence of these links is the bug that got resolved in this BZ.
Comment 10 Ori Liel 2012-08-27 08:04:07 EDT
merged upstream, commit b8fd345dc79b841a4e82330e377fd8adb7e5ed19
Comment 12 Anand Nande 2012-08-27 11:11:07 EDT
Simon,

Thanks, raised an RFE : https://bugzilla.redhat.com/show_bug.cgi?id=852086
Comment 13 Jakub Libosvar 2012-10-02 10:58:54 EDT
Verified rhevm-restapi-3.1.0-18.el6ev.noarch

Note You need to log in before you can comment on or make changes to this bug.