Bug 849442 - Configure Apache mod_headers during installation
Configure Apache mod_headers during installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
: Regression, Reopened
Depends On:
Blocks: 845832
  Show dependency treegraph
 
Reported: 2012-08-19 09:31 EDT by Michael Pasternak
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: is7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16563 None None None Never

  None (edit)
Description Michael Pasternak 2012-08-19 09:31:44 EDT
Description of problem:

more info can be found at https://bugzilla.redhat.com/show_bug.cgi?id=845832#c30
Comment 1 Juan Hernández 2012-08-22 06:56:22 EDT
From the comments in bug 845832 it is not clear to me if this is really needed, but if it is I think this change can be the solution:

http://gerrit.ovirt.org/7399
Comment 2 Michael Pasternak 2012-08-22 07:10:45 EDT
this change is 'must' to allow clients using 'Expect' header (including our sdk)
Comment 3 Juan Hernández 2012-08-22 07:12:07 EDT
I trust you.
Comment 4 Juan Hernández 2012-08-23 15:25:36 EDT
The proposed change has been merged upstream:

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=a441804b8b326d556dc1df9635548ee9ca494aa9
Comment 7 Michael Pasternak 2013-07-01 10:00:11 EDT
*** Bug 979737 has been marked as a duplicate of this bug. ***
Comment 8 Michael Pasternak 2013-07-01 10:03:47 EDT
looks like regression was caused by the [1].

[1] http://gerrit.ovirt.org/#/c/13318/
Comment 10 Alon Bar-Lev 2013-07-16 05:25:59 EDT
Just for the record, yet another reason why not to use Expect in applications.

From the RFC[1]
"""
The Expect mechanism is hop-by-hop: that is, an HTTP/1.1 proxy MUST return a 417 (Expectation Failed) status if it receives a request with an expectation that it cannot meet. However, the Expect request-header itself is end-to-end; it MUST be forwarded if the request is forwarded. 
"""

This means that Expect will not work when using http proxy, and this use case should be valid when accessing the api as ell.

[1] http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html
Comment 12 Ilia Meerovich 2013-08-07 07:03:33 EDT
regression (that previous bug solution caused) was solved in is7.
Comment 15 Itamar Heim 2014-01-21 17:28:02 EST
Closing - RHEV 3.3 Released
Comment 16 Itamar Heim 2014-01-21 17:28:04 EST
Closing - RHEV 3.3 Released
Comment 17 Itamar Heim 2014-01-21 17:30:59 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.