Bug 849458 - No "java" capability for java-1.7.0-openjdk
No "java" capability for java-1.7.0-openjdk
Status: CLOSED DUPLICATE of bug 916288
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
6.4
All Linux
medium Severity low
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
:
: 850523 (view as bug list)
Depends On:
Blocks: 835616 960054
  Show dependency treegraph
 
Reported: 2012-08-19 11:50 EDT by Scott Dodson
Modified: 2013-05-07 07:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-07 07:11:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2012-08-19 11:50:56 EDT
Similar to the problem described in Bug 847837, java-1.7.0-openjdk does not provide the base "java" capability which means that when applications, such as jbossas-standalone from EAP6, are installed they will pull in other JVMs in order to meet these dependencies even when java-1.7.0-openjdk is already installed.

Actual results :
$rpm -q --provides java-1.7.0-openjdk | grep -wE 'java.? '
java7 = 1:1.7.0

Expected :
rpm -q --provides java-1.7.0-openjdk | grep -wE 'java.? '
java = 1:1.7.0
java7 = 1:1.7.0
Comment 2 Deepak Bhole 2012-08-21 14:25:19 EDT
*** Bug 850523 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2012-09-07 01:36:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Arnout Engelen 2012-12-06 10:22:56 EST
I'm also seeing this issue: 'tomcat6' depends on 'java' which is not provided by java-1.7.0-openjdk

This prevents us from upgrading to java7 even though java6 is planned to go EOL next february.
Comment 8 jiri vanek 2013-05-07 07:11:00 EDT

*** This bug has been marked as a duplicate of bug 916288 ***

Note You need to log in before you can comment on or make changes to this bug.