Bug 849459 - jetty user not created
jetty user not created
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: jetty (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On: 849927
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 11:57 EDT by Mads Kiilerich
Modified: 2012-08-21 07:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 07:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2012-08-19 11:57:13 EDT
I see boot failures:

[root@D610 ~]# systemctl status systemd-tmpfiles-setup.service
systemd-tmpfiles-setup.service - Recreate Volatile Files and Directories
	  Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-setup.service; static)
	  Active: failed (Result: exit-code) since Sun, 19 Aug 2012 17:34:10 +0200; 15min ago
	    Docs: man:tmpfiles.d(5)
	Main PID: 612 (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/systemd-tmpfiles-setup.service

Aug 19 17:34:08 D610 systemd-tmpfiles[612]: [/etc/tmpfiles.d/jetty.conf:1] Unknown user 'jetty'.

Running the commands from jetty's %pre scriptlet without /dev/null redirection shows:
useradd: UID 110 is not unique

I have
haproxy:x:110:109:HAProxy user:/var/lib/haproxy:/bin/false

1: Redirecting adduser output to /dev/null is not a good idea.
2: Hardcoding the UID is not a good idea.

Reference: https://fedoraproject.org/wiki/Packaging:UsersAndGroups
Comment 1 Mikolaj Izdebski 2012-08-21 07:11:27 EDT
> Running the commands from jetty's %pre scriptlet without /dev/null
> redirection shows:
> useradd: UID 110 is not unique
>
> I have
> haproxy:x:110:109:HAProxy user:/var/lib/haproxy:/bin/false

UID 110 was reserved for Jetty, but it wasn't documented (until now).
No other package should create user with UID 110 and you shouldn't create it yourself either.

> 1: Redirecting adduser output to /dev/null is not a good idea.

I agree. Only getent output was supposed to be redirected. I will fix this in rawhide.

> 2: Hardcoding the UID is not a good idea.

That is a common practice in Fedora. Whether I agree or not, this is not the right place to discuss that. You can discuss this topic on fedora-devel mailing list.

Note You need to log in before you can comment on or make changes to this bug.