Bug 849488 - Example proxy-server.conf file is incorrect and misleading
Example proxy-server.conf file is incorrect and misleading
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
2.0
All All
medium Severity medium
: ---
: ---
Assigned To: Divya
SATHEESARAN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 19:06 EDT by Brad Hubbard
Modified: 2015-05-13 11:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-10 03:17:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hubbard 2012-08-19 19:06:49 EDT
Description of problem:
There is an error in the administration guide in section 19.4.2. "Configuring Proxy Server".

The sample config file is incorrect as follows.

user_test_tester=testing.admin   <--- No space

Whereas the example in section 19.4.1. "Adding Users" is correct.

user_test_tester = testing .admin  <------- Note the space between "testing" and ".admin"

The space is actually necessary and authentication will fail if it is not there.

Version-Release number of selected component (if applicable):
RHS 2.0
Comment 1 Divya 2012-09-04 07:46:01 EDT
I have made the necessary changes and the updated documentation is available at: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/ch19s04s02.html
Comment 2 Brad Hubbard 2012-09-04 17:01:16 EDT
There still doesn't appear to be the necessary spaces in the sample?
Comment 3 SATHEESARAN 2012-10-10 03:00:02 EDT
Divya,

As per your reference link to the documentation, http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/ch18s04.html , the section 18.4.1 seems to be modified, but section 18.4.2, the sample proxy-server.conf , has 2 errors,

1. There is no space before and after "="
2. In one of the line (9th line), there is a space before period (".")

So moving this bug to ON_DEV state
Comment 4 Divya 2012-12-07 03:24:11 EST
Fixed all the comments, updated documentation is available at:http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.0/html/Administration_Guide/ch18s04s02.html
Comment 5 SATHEESARAN 2012-12-07 04:41:21 EST
Verified the updated Documentation.
Moving it to VERIFIED state

Note You need to log in before you can comment on or make changes to this bug.