Bug 849524 - SELinux is preventing plugin-config from 'execmod' accesses on the file /usr/lib/nvidia/libnvidia-glcore.so.304.37.
SELinux is preventing plugin-config from 'execmod' accesses on the file /usr/...
Status: CLOSED DUPLICATE of bug 849523
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:12829f2081fc601a1837a5c3040...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 01:06 EDT by Aldrian Obaja
Modified: 2012-08-20 06:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 06:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aldrian Obaja 2012-08-20 01:06:47 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.2-1.fc17.i686
time:           Mon 20 Aug 2012 01:06:16 PM SGT

description:
:SELinux is preventing plugin-config from 'execmod' accesses on the file /usr/lib/nvidia/libnvidia-glcore.so.304.37.
:
:*****  Plugin allow_execmod (91.4 confidence) suggests  **********************
:
:If you want to allow plugin-config to have execmod access on the libnvidia-glcore.so.304.37 file
:Then you need to change the label on '/usr/lib/nvidia/libnvidia-glcore.so.304.37'
:Do
:# semanage fcontext -a -t textrel_shlib_t '/usr/lib/nvidia/libnvidia-glcore.so.304.37'
:# restorecon -v '/usr/lib/nvidia/libnvidia-glcore.so.304.37'
:
:*****  Plugin catchall (9.59 confidence) suggests  ***************************
:
:If you believe that plugin-config should be allowed execmod access on the libnvidia-glcore.so.304.37 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-config /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_config_t:
:                              s0-s0:c0.c1023
:Target Context                system_u:object_r:lib_t:s0
:Target Objects                /usr/lib/nvidia/libnvidia-glcore.so.304.37 [ file
:                              ]
:Source                        plugin-config
:Source Path                   plugin-config
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           xorg-x11-drv-nvidia-libs-304.37-1.fc17.i686
:Policy RPM                    selinux-policy-3.10.0-145.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.2-1.fc17.i686 #1 SMP Wed Aug
:                              15 16:52:27 UTC 2012 i686 i686
:Alert Count                   3
:First Seen                    2012-08-19 20:03:42 SGT
:Last Seen                     2012-08-20 10:45:31 SGT
:Local ID                      da3cca69-217c-477e-91de-ba8c864f67fe
:
:Raw Audit Messages
:type=AVC msg=audit(1345430731.903:62): avc:  denied  { execmod } for  pid=1750 comm="plugin-config" path="/usr/lib/nvidia/libnvidia-glcore.so.304.37" dev="dm-1" ino=1058821 scontext=unconfined_u:unconfined_r:mozilla_plugin_config_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=file
:
:
:Hash: plugin-config,mozilla_plugin_config_t,lib_t,file,execmod
:
:audit2allow
:
:#============= mozilla_plugin_config_t ==============
:allow mozilla_plugin_config_t lib_t:file execmod;
:
:audit2allow -R
:
:#============= mozilla_plugin_config_t ==============
:allow mozilla_plugin_config_t lib_t:file execmod;
:
Comment 1 Daniel Walsh 2012-08-20 06:26:40 EDT

*** This bug has been marked as a duplicate of bug 849523 ***

Note You need to log in before you can comment on or make changes to this bug.