Bug 849537 - web-admin: first login over WAN - gives the impression that the UI is stuck until login is completed
web-admin: first login over WAN - gives the impression that the UI is stuck u...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: vszocs
Lukas Svaty
ux
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 02:55 EDT by Yaniv Kaul
Modified: 2013-07-03 22:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: si19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-08-20 02:55:21 EDT
Description of problem:
When logging in to the webadmin over WAN, the experience isn't very pleasant: 
After entering the credentials and clicking the login button, the password field is cleared right away, the login button is NOT disabled, and it appears, for ~20 seconds, that everything is stuck. There is no wait cursor, nothing.

Version-Release number of selected component (if applicable):
SI14

How reproducible:


Steps to Reproduce:
1. Login to the webui for the first time, over WAN.
2.
3.
  
Actual results:


Expected results:
- 'Login' button disabled.
- Wait cursor.

Additional info:
Comment 1 Gilad Chaplik 2012-08-21 08:53:27 EDT
pushed upstream (http://gerrit.ovirt.org/#/c/7376/1)
Comment 4 Einav Cohen 2012-08-29 06:15:49 EDT
need to add a complementary patch that takes care of having an animated mouse cursor also during the place transition - not only while uicommon model is in progress.
Comment 5 vszocs 2012-09-03 12:25:01 EDT
Complementary patch submitted upstream: http://gerrit.ovirt.org/7720
Comment 6 vszocs 2012-09-10 05:22:54 EDT
Complementary patch merged upstream
Comment 7 vszocs 2012-09-10 05:27:10 EDT
Complementary patch submitted downstream: https://gerrit.eng.lab.tlv.redhat.com/1983
Comment 8 vszocs 2012-09-10 08:30:36 EDT
Complementary patch merged downstream
Comment 9 Einav Cohen 2012-09-11 09:38:00 EDT
moving back to assigned, since need to solve the issue with wrong-credentials scenario. Once it is merged downstream, the BZ can move to MODIFIED.
Comment 10 vszocs 2012-09-11 12:24:46 EDT
Fix patch upstream: http://gerrit.ovirt.org/7931
Fix patch downstream: https://gerrit.eng.lab.tlv.redhat.com/2051
Comment 11 vszocs 2012-09-12 12:18:14 EDT
Fix patch merged upstream and downstream

Note You need to log in before you can comment on or make changes to this bug.