Bug 849555 - "Learn More" link in the header of the website was not valid on INT.
"Learn More" link in the header of the website was not valid on INT.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Wesley Hearn
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 03:48 EDT by Mengjiao Gao
Modified: 2015-05-14 21:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mengjiao Gao 2012-08-20 03:48:21 EDT
Description of problem:
"Learn More" link in the header of the website was not valid on INT.The redirected page of this link displayed error with the following message:"This webpage has a redirect loop
The webpage at https://int.openshift.redhat.com/community/paas has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer."

Version-Release number of selected component (if applicable):
INT

How reproducible:
always

Steps to Reproduce:
1.Go to openshift website on INT.
2.Click the "Learn more" link in the header.
3.
  
Actual results:
It returned a page not valid.

Expected results:
It should be redirected to the learn more page successful.


Additional info:
Comment 1 Clayton Coleman 2012-08-20 10:24:29 EDT
It looks like this is related to the change operations made as part of the release ticket.  /paas was supposed to redirect to /community/paas, but it looks like all URLs ending in /paas redirect to themselves infinitely.

Anderson, can you check out whether this is a redirect bug?
Comment 2 Anderson Silva 2012-08-20 10:34:47 EDT
I am assigning this to Wesley. One possible fix is to change the redirect from:

RewriteRule /paas https://int.openshift.redhat.com/community/paas [R,L]

to

RewriteRule ^/paas$ https://int.openshift.redhat.com/community/paas [R,L]
Comment 3 Mengjiao Gao 2012-08-20 22:58:44 EDT
Tested the "Learn More" link in the new INT (same with devenv_2036).It can be redirected to the right page now, So I will put it verified.

Note You need to log in before you can comment on or make changes to this bug.