Bug 849572 - Strange behaviour of iptables-save
Strange behaviour of iptables-save
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptables (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: iptables-maint-list
qe-baseos-daemons
:
Depends On:
Blocks: 849573
  Show dependency treegraph
 
Reported: 2012-08-20 04:40 EDT by David Spurek
Modified: 2015-03-02 00:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 849573 (view as bug list)
Environment:
Last Closed: 2012-08-20 07:05:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2012-08-20 04:40:36 EDT
Description of problem:
Strange behaviour of iptables-save. After service iptables stop command iptables-save print nothing to ouput. Then I run iptables -L and now iptables-save output three lines. I think that iptables -L is read only operation and this not may effect for iptables-save. 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.service iptables stop
2.iptables-save
3.iptables -L
4.iptables-save
  
Actual results:
first iptables-save prints nothing

second iptables-save prints:
iptables-save# Generated by iptables-save v1.3.5 on Mon Aug 20 04:09:43 2012
*filter
:INPUT ACCEPT [22:1432]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [16:2896]
COMMIT
# Completed on Mon Aug 20 04:09:43 2012


Expected results:
same behaviour of both iptables-save commands 

Additional info:
Comment 1 RHEL Product and Program Management 2012-08-20 04:59:18 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 Thomas Woerner 2012-08-20 07:05:59 EDT
iptables-save dumps all IPv4 iptables rules. After service iptables stop, all netfilter firewall mudules are unloaded. Using "iptables -L" loads the base firewall modules if they are not loaded already, this results in the standard accept policy rules.

This is expected behaviour.

Note You need to log in before you can comment on or make changes to this bug.