Bug 849589 - Node execution failure when trigger 'show-port' event for application with jenkins client embedded
Node execution failure when trigger 'show-port' event for application with je...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 05:47 EDT by xjia
Modified: 2015-07-19 20:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 13:30:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2012-08-20 05:47:43 EDT
Description of problem:
Node execution failure, When use rest api to show port. 
<---snip--->
<messages>
    <message>
      <severity>INFO</severity>
      <text>Application jboss1 called show port: No proxy ports defined</text>
      <exit-code nil="true"></exit-code>
      <field nil="true"></field>
    </message>
  </messages>
<--snip--->
Version-Release number of selected component (if applicable):
devenv_2031
rhc-client(0.97.12)

How reproducible:
Always

Steps to Reproduce:
1.Create an app:
rhc app create -a jboss1 -t jbossas-7 --enable-jenkins -pxx
2.Use REST API to "show-port"
curl -k -X POST -H 'Accept: application/xml' -d event=show-port --user jia:jia https://ec2-23-20-203-15.compute-1.amazonaws.com/broker/rest/domains/pjad/applications/jboss1/events

  
Actual results:
<---snip--->
<messages>
    <message>
      <severity>INFO</severity>
      <text>Application jboss1 called show port: No proxy ports defined</text>
      <exit-code nil="true"></exit-code>
      <field nil="true"></field>
    </message>
  </messages>
<--snip--->

Expected results:


Additional info:

The log (/var/www/stickshift/broker/log/development.log):
[1950] DEBUG DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f14efe93c10>
[1950] DEBUG DEBUG: rpc_client.custom_request('cartridge_do', {:cartridge=>"jenkins-client-1.4", :action=>"show-port", :args=>"'jboss1' 'pjad' '35aac5d00cbf48efa26c0124a7c94290'"}, @id, {'identity' => @id})
[1950] DEBUG DEBUG: [#<MCollective::RPC::Result:0x7f14efdc6350 @results={:statusmsg=>"cartridge_do_action ERROR action 'show-port' not found.", :statuscode=>1, :data=>{:exitcode=>127}, :sender=>"ip-10-202-102-168"}, @action="cartridge_do", @agent="stickshift">]
[1950] DEBUG DEBUG: Cartridge command jenkins-client-1.4::show-port exitcode = 127
[1950] ERROR Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.


Related links:
https://bugzilla.redhat.com/show_bug.cgi?id=812805
Comment 1 Dan McPherson 2012-08-20 10:18:12 EDT
Looks like it might be a dup of: 849385
Comment 2 Rajat Chopra 2012-08-20 13:30:02 EDT
This is not a bug. Behaviour is expected.

For a non-scalable app, there are no ports exposed by default. So, the curl call conveys correctly that 'No proxy ports defined'.

As far as the logs showing Node execution failure, the call is exiting with code 127 indicating that jenkins cartridge does not have a show-port facility (it does not have an expose-port either), and we process it correctly by ignoring that failure.

Note You need to log in before you can comment on or make changes to this bug.