Bug 849597 - The fullscreen toolbar cannot be reentered
The fullscreen toolbar cannot be reentered
Status: CLOSED DUPLICATE of bug 689850
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 05:59 EDT by Milan Barta
Modified: 2015-10-27 20:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 11:22:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Barta 2012-08-20 05:59:41 EDT
Description of problem:
After connecting to a VM using the remote-viewer (spice protocol), then switching to fullscreen mode and moving the mouse cursor over the upper fullscreen toolbar and away, the toolbar rolls up and hides. After that the toolbar cannot be reentered.


Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. connect to a VM using remote-viewer
2. switch to fullscreen
3. move the mouse cursor over the upper toolbar
4. move the mouse cursor away from the toolbar
5. move the mouse cursor to the very top of the screen
  
Actual results:
the toolbar doesn't show up again

Expected results:
the toolbar does show up

Additional info:
the toolbar can be showed again only after switching to a window mode and back to fullscreen using the shift+f11 shortcut
Comment 2 Milan Barta 2012-08-20 06:12:18 EDT
Just found out that the problem only occurs with Desktop Effects enabled in Gnome. When disabled the toolbar shows up again as expected.

compiz-0.8.2-24.el6.x86_64
Comment 3 Geyang Kong 2012-09-06 22:36:13 EDT
I cannot reproduce this bug since I cannot enable "Desktop Effects" in guest, when I tried to do that, I always got error said: Desktop effects require hardware 3D support. Can you provide some ways I can get away from that error?
Comment 4 Milan Barta 2012-09-07 02:06:44 EDT
I didn't make myself clear, sorry. The Desktop Effects are to be enabled in client system, not guest.
I've done some more research and I found bug 689850  which I think is what's causing the problem and therefore making the remote-viewer in fullscreen pretty unusable.
Comment 5 Geyang Kong 2012-10-15 01:35:31 EDT
I'm sorry but I still cannot reproduce this bug with same build as yours. I've enabled compiz on my host, then followed your steps, and I also tried on both VNC and SPICE guests, but it always worked well. Can you still reproduce this bug and provide some more details about this?
Comment 6 Milan Barta 2012-10-15 05:09:12 EDT
Yes, the bug is still there (virt-viewer-0.5.2-11.el6.x86_64, spice-gtk-0.14-3.el6.x86_64).

I'll try to describe every step I do to reproduce:

On Client:
1. Enable Compiz desktop effects (Through Gnome "System" menu -> "Preferences" -> "Desktop Effects" -> choose "Compiz"
2. Connect to VM (for example through RHEVM portal) using remote-viewer
3. Switch to fullscreen (either through remote-viewer menu or "Shift+F11")
4. The upper toolbar shows -> after you move the mouse over it and away off it, it disappears
5. When you move the mouse to the very top of the screen, the toolbar should appear again, but it doesn't.

As I said before, I think it is most probably caused by a compiz issue described in bug 689850 (generally the topmost row of pixels doesn't respond to mouse actions).
Comment 7 Geyang Kong 2012-10-18 02:10:31 EDT
I still cannot reproduce this bug by very following your steps in comment 6, and neither can I reproduce bug 689580. I need to confirm some tips.
1. Have your mouse pointer grabbed by guest? If your guest grab your mouse, then you must release it from guest and then move it to the top. Only in this way the tool bar will work.
2. I've tried this with your steps on a Lenovo thinkcenter host and 2 DELL OPTIPLEX 580 hosts. All of them work well.
3. What's your host's model, do you use some special hardwares such as video card?
Comment 8 Geyang Kong 2012-10-18 02:15:02 EDT
(In reply to comment #7)
> I still cannot reproduce this bug by very following your steps in comment 6,
> and neither can I reproduce bug 689580. I need to confirm some tips.
> 1. Have your mouse pointer grabbed by guest? If your guest grab your mouse,
> then you must release it from guest and then move it to the top. Only in
> this way the tool bar will work.
> 2. I've tried this with your steps on a Lenovo thinkcenter host and 2 DELL
> OPTIPLEX 580 hosts. All of them work well.
> 3. What's your host's model, do you use some special hardwares such as video
> card?

Sorry, it should by bug 689856, I typed it wrong.
Comment 9 Geyang Kong 2012-10-18 02:16:10 EDT
(In reply to comment #7)
> I still cannot reproduce this bug by very following your steps in comment 6,
> and neither can I reproduce bug 689580. I need to confirm some tips.
> 1. Have your mouse pointer grabbed by guest? If your guest grab your mouse,
> then you must release it from guest and then move it to the top. Only in
> this way the tool bar will work.
> 2. I've tried this with your steps on a Lenovo thinkcenter host and 2 DELL
> OPTIPLEX 580 hosts. All of them work well.
> 3. What's your host's model, do you use some special hardwares such as video
> card?

Sorry, it should by bug 689850, I typed it wrong.
Comment 10 Milan Barta 2012-10-18 06:35:29 EDT
Ok, just found out that the toolbar issue only occurs when "Workspaces on a Cube" option in the Desktop Effects dialog is disabled.
Could you try to reproduce the bug with this option off, please?
Comment 11 Geyang Kong 2012-10-18 07:02:13 EDT
Thanks very much for your support, I can reproduce it now.
Comment 13 Marc-Andre Lureau 2013-05-08 11:22:01 EDT
As this is clearly for me the compiz bug 689850, closing as dup.

Feel free to reopen if you feel otherwise.

*** This bug has been marked as a duplicate of bug 689850 ***

Note You need to log in before you can comment on or make changes to this bug.