Bug 849606 - provide option to disable io-threads least-priority
provide option to disable io-threads least-priority
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
Ben Turner
:
Depends On: 843704
Blocks: 851030
  Show dependency treegraph
 
Reported: 2012-08-20 06:34 EDT by Pranith Kumar K
Modified: 2013-09-23 18:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 843704
: 851030 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-08-20 06:34:23 EDT
+++ This bug was initially created as a clone of Bug #843704 +++

Description of problem:
In some kind of load, fops with least priority(self-heal fops) are facing starvation in io-threads. Provide an option to disable least-priority altogether.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from vbellur@redhat.com on 2012-07-30 14:16:07 EDT ---

CHANGE: http://review.gluster.com/3743 (performance/io-threads: Provide option to turn off least-priority) merged in master by Anand Avati (avati@redhat.com)
Comment 2 Ben Turner 2013-08-12 16:01:17 EDT
Verified on glusterfs-3.4.0.18rhs-1.el6rhs.x86_64:

[root@storage-qe08 ~]# gluster volume set testvol enable-least-priority on
volume set: success
[root@storage-qe08 ~]# gluster volume set testvol enable-least-priority off
volume set: success

Option: performance.enable-least-priority
Default Value: on
Description: Enable/Disable least priority
Comment 3 Scott Haines 2013-09-23 18:38:57 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 4 Scott Haines 2013-09-23 18:41:32 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.