Bug 849631 - There is no remind message when trying to downgrade with more than 3 applications.
There is no remind message when trying to downgrade with more than 3 applicat...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 07:59 EDT by Yujie Zhang
Modified: 2015-05-14 21:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-08-20 07:59:32 EDT
Description of problem:

I upgraded my account and created 4 applications, and then I tried to downgraded my account and after I click the "Yes, I want to downgrade" button ,it will redirect to the page itself, there is no error message or remind message to indicate user the reason.

Version-Release number of selected component (if applicable):

devenv_2031

How reproducible:
always

Steps to Reproduce:
1.Go to openshift website and login
2.Upgrade the account and create more than 3 applications
3.Try to downgrade the account.
  
Actual results:

It will redirect to the same page, and no error message or remind message.

Expected results:

There should be error message or remind message to indicate user the reason rather than redirect to the page itself.

Additional info:
Comment 1 Clayton Coleman 2012-08-20 13:14:15 EDT
Fixed in https://github.com/openshift/li/pull/275
Comment 2 Mengjiao Gao 2012-08-21 05:24:23 EDT
When I tested this issue on devenv_2041, I found that I cannot update my plans. After I select the megashift plan , I filled the Account Information and the  payment method page. Then I clicked "upgrage me!" ,but get a error page said:
"Routing Error

No route matches "/account/plans/megashift/upgrade"".
Comment 3 Mengjiao Gao 2012-08-22 04:16:39 EDT
Tested this issue on devenv_2047. When I tried to downgrade with more than 3 app created, the page will display a remind message to advice me to delete app. So I will put this issue to verified.

Note You need to log in before you can comment on or make changes to this bug.