Bug 849638 - Unable to search test plans
Unable to search test plans
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.8.0
Unspecified FreeBSD
unspecified Severity high
: ---
: ---
Assigned To: Xiangyang Chu
tools-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 08:19 EDT by Jenny Galipeau
Modified: 2016-01-04 00:26 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-26 21:55:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2012-08-20 08:19:56 EDT
Description of problem:
after the latest upgrade, no longer able to search test plans.  Any search string entered returns no results

Version-Release number of selected component (if applicable):
Nitrate 3.8.0 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Xin Gao 2012-08-21 01:13:57 EDT
Hi Jenny:
I checked three search modules(Advanced Search, PLANNING->Search Plan, Quick search), didn't find any problem.
test env:
Fedora16 + Chrome21/Firefox14.0.1.
Fedora14 + Chrome13
Fedora14 + Firefox3.6
So could you provide us more detail info for this problem? such as your env, steps.

Thanks very much
Xin

(In reply to comment #0)
> Description of problem:
> after the latest upgrade, no longer able to search test plans.  Any search
> string entered returns no results
> 
> Version-Release number of selected component (if applicable):
> Nitrate 3.8.0 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
Comment 2 Jenny Galipeau 2012-08-21 08:28:05 EDT
First env :: F17, firefox-14.0.1-1
Second env :: RHEL 6.3, firefox-10.0.6-1

1) open tcms in browser
2) in Test Plan quicksearch field enter a search string like "SSSD" or "IPA"
  * brings you to Search Plan page
  * no test plans found
3) enter "SSSD" or "IPA" in Plan Name field and click Search
  * no test plans found
4) (try different search criteria) Select IDM QE for Environment Group and click search
  * no test plans found
Comment 3 Xiangyang Chu 2012-08-23 01:38:06 EDT
Hi Jenny,

All three search you tried works for me on F16 + firefox v14.0.1.
Please look around and see if it works on others computer.
And is it possible that you happen to change some settings about disable JavaScript?
Comment 4 Jenny Galipeau 2012-08-23 08:00:21 EDT
HI:
As of yesterday, searches have started working.  I am not sure what changed.  For now, I think we can close this bug and if it happens again, I will re-open it.
Thanks
Jenny
Comment 5 yawei Li 2012-08-23 21:57:44 EDT
Thanks for your feedback, Jenny.

We don't tough tcms production after the release. So close this bug. if it happens again, please record it, or ping in #tcms channel.
Comment 6 jihu 2012-08-24 02:20:12 EDT
Firefox 14.0.1

Using upper FF version ,can't search test plan ,test case,test run.
Comment 7 Zheng Liu 2012-08-24 03:38:19 EDT
The reason of this problem is that JS script is disabled on FF. You can enable JS script as below:
1. Edit -> Preferences -> Content -> check 'Enable JavaScript'.
2. If you installed Firebug, please go to Script panel to make sure the script is enabled.

Note You need to log in before you can comment on or make changes to this bug.