Bug 849659 - Client Error when Push build to Koji
Client Error when Push build to Koji
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-fedorapackager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 09:49 EDT by Robin Lee
Modified: 2012-08-27 04:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 04:46:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Lee 2012-08-20 09:49:55 EDT
Description of problem:
"Client Error" shown when Push build to Koji

Version-Release number of selected component (if applicable):
eclipse-emf-2.8.0-1.fc17.noarch
eclipse-jdt-4.2.0-3.fc17.x86_64
eclipse-egit-2.0.0-1.fc17.noarch
eclipse-equinox-osgi-4.2.0-3.fc17.x86_64
eclipse-rcp-4.2.0-3.fc17.x86_64
eclipse-linuxprofilingframework-1.0.0-2.fc17.x86_64
eclipse-emf-core-2.8.0-3.fc17.x86_64
eclipse-pydev-2.6.0-1.fc17.noarch
eclipse-rpm-editor-1.0.0-1.fc17.x86_64
eclipse-platform-4.2.0-3.fc17.x86_64
eclipse-rse-3.3.1-1.fc17.noarch
eclipse-cdt-8.1.0-0.6.junom6.fc17.x86_64
eclipse-changelog-2.7.0-7.fc17.noarch
eclipse-swt-4.2.0-3.fc17.x86_64
eclipse-jgit-2.0.0-1.fc17.noarch
eclipse-fedorapackager-0.3.2-4.fc17.noarch
eclipse-pde-4.2.0-3.fc17.x86_64
eclipse-rpmstubby-1.0.0-1.fc17.noarch
eclipse-epic-0.6.44-1.fc17.noarch

How reproducible:
Start 'Push build to Koji'

Additional info:
eclipse.buildId=I20120608-1400
java.version=1.7.0_05-icedtea
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

Error
Mon Aug 20 21:44:28 CST 2012
Something unexpected happened: Client error

org.fedoraproject.eclipse.packager.koji.api.errors.KojiHubClientException: Client error
	at org.fedoraproject.eclipse.packager.koji.api.AbstractKojiHubBaseClient.build(AbstractKojiHubBaseClient.java:131)
	at org.fedoraproject.eclipse.packager.koji.api.KojiBuildCommand.call(KojiBuildCommand.java:209)
	at org.fedoraproject.eclipse.packager.koji.api.KojiBuildJob.run(KojiBuildJob.java:134)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.apache.xmlrpc.XmlRpcException: No matching build target found: dist-rawhide
	at org.apache.xmlrpc.client.XmlRpcStreamTransport.readResponse(XmlRpcStreamTransport.java:197)
	at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:156)
	at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:143)
	at org.apache.xmlrpc.client.XmlRpcSunHttpTransport.sendRequest(XmlRpcSunHttpTransport.java:69)
	at org.apache.xmlrpc.client.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:56)
	at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:167)
	at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:158)
	at org.apache.xmlrpc.client.XmlRpcClient.execute(XmlRpcClient.java:147)
	at org.fedoraproject.eclipse.packager.koji.api.AbstractKojiHubBaseClient.build(AbstractKojiHubBaseClient.java:129)
	... 3 more
Comment 1 Severin Gehwolf 2012-08-20 12:39:27 EDT
Thanks for the bug report! It looks like we are using the wrong build target "dist-rawhide" over "rawhide". Keep your eyes peeled for an update with a fix for this.
Comment 2 Severin Gehwolf 2012-08-21 04:05:27 EDT
Robin: This build should fix your issue:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4407638

You could download the RPM, yum localinstall it and try it out if you feel up to it :) Let us know if this build fixes your issue. Thanks!
Comment 3 Robin Lee 2012-08-22 09:33:02 EDT
(In reply to comment #2)
> Robin: This build should fix your issue:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4407638
Great, it works now.
Comment 4 Severin Gehwolf 2012-08-22 09:52:08 EDT
Cool. Here is the update which will fix this:
https://admin.fedoraproject.org/updates/eclipse-fedorapackager-0.4.1-1.fc17

Feel free to give karma :)
Comment 5 Severin Gehwolf 2012-08-27 04:46:19 EDT
Update pushed to stable. I'm closing this one as fixed.

Note You need to log in before you can comment on or make changes to this bug.