Bug 849698 - MIN_GEAR setting for a cartridge is not working.
MIN_GEAR setting for a cartridge is not working.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Luke Meyer
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-20 11:46 EDT by xjia
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 11:26:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2012-08-20 11:46:40 EDT
Description of problem:
Change the MIN_GEAR setting for a cartridge to 'n' in the manifest file.Create a scalable app,but the gear's number is also 2. 

Version-Release number of selected component (if applicable):
Alpha 2012-08-09.2

How reproducible:
Always

Steps to Reproduce:
1.Modify /usr/libexec/stickshift/cartridges/php-5.3/info/manifest.ymle   Min: 3
2.Restart stickshift-broker service
3.Create an scalable app about php
rhc app create -a php1 -t php-5.3 -pxx -s
  
Actual results:
The gear's number is 2.

Expected results:
The gear's number is 4. (3+1=4)

Additional info:
Comment 1 Abhishek Gupta 2012-08-23 17:56:24 EDT
Works for me.

I was able to get this to work on the devenv_2064 today. Instead of 3, I set the Min gears to 2 for php-5.3 cartridge. When I created an application, it had 2 gears for php and 1 for haproxy totalling 3 gears for the application.

I also tried to scale down and got a validation error message saying, 
"Cannot scale below minimum gear requirements for group '2'"

Did you have a gear limit of 4+ for your user account? Also, can you try this again on the latest devenv and if it still fails, it would be nice to try and debug on your instance itself.
Comment 2 xjia 2012-08-23 21:56:30 EDT
On devenv, it works perfectly.

The issue only exists in on-premise origin. This issue's product is assigned to  "Openshift On-Premise". :)
Comment 3 Abhishek Gupta 2012-08-23 22:04:45 EDT
Krishna: Refer comments above. Can you please co-ordinate with Brenton on this bug as I am going to be away on vacation starting tomorrow?
Comment 4 John Keck 2012-11-13 11:17:49 EST
Need to verify post GA that this is still a problem.
Comment 6 Brenton Leanhardt 2012-12-05 15:14:42 EST
Would you mind re-testing this against the latest version of the product?
Comment 7 xjia 2012-12-07 02:34:01 EST
(In reply to comment #6)
It doesn't work yet with the lastest puddle (OSE 2012-12-06.1). Even I restart broker and node system, it still can't work.
Comment 8 xjia 2012-12-07 02:59:11 EST
After I update the file /usr/libexec/openshift/cartridges/php-5.3/info/manifest.yml. Then must execute "cd /var/www/openshift/broker
bundle exec rake tmp:clear". Finaly, it can work.

Whatever, I verify it. 

Version:
OSE 2012-12-06.1
Comment 9 Luke Meyer 2012-12-07 11:26:20 EST
We haven't touched this, so I assume it shipped correctly with 1.0

Note You need to log in before you can comment on or make changes to this bug.