Bug 849826 - libgstbcmdec.so: undefined symbol: gst_video_format_new_caps
libgstbcmdec.so: undefined symbol: gst_video_format_new_caps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libcrystalhd (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 00:46 EDT by Stan King
Modified: 2012-08-31 16:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 683565
Environment:
Last Closed: 2012-08-30 16:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output of "gst-inspect -b" under Fedora 17, in the above scenario (289 bytes, text/plain)
2012-08-21 00:46 EDT, Stan King
no flags Details

  None (edit)
Description Stan King 2012-08-21 00:46:38 EDT
Created attachment 605833 [details]
The output of "gst-inspect -b" under Fedora 17, in the above scenario

+++ This bug was initially created as a clone of Bug #683565 +++

Installed fresh Fedora 14 i686 on Intel D510MO board
with BCM70012 based mini PCIe accelerator installed.
Performed any outstanding updates.

Steps to Reproduce:
1. Installed gstreamer-plugin-cystalhd, which pulls
   in libcrystalhd and associated firmware.
2. Expunged .gstreamer-0.10 in home directory
3. Ran gst-inspect -b
  
Actual results:
(gst-plugin-scanner:2098): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstbcmdec.so': /usr/lib/gstreamer-0.10/libgstbcmdec.so: undefined symbol: gst_video_format_new_caps

Expected results:
No blacklisted plugins to be listed.

Additional info:
Kernel 2.6.35.11-83.fc14.i686.PAE #1

Relevant dmesg:
[   11.705624] Broadcom 70012 Decoder 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   11.720890] Broadcom 70012 Decoder 0000:02:00.0: irq 46 for MSI/MSI-X
[   11.721173] Starting BCM70012 Device
[   11.987144] Stopping BCM70012 Device
[   12.140305] Broadcom 70012 Decoder 0000:02:00.0: setting latency timer to 64

--- Additional comment from johnp@redhat.com on 2011-03-09 14:03:27 EST ---

Not sure why this was assigned to me in any case the maintainer for the actual plugin might know more.  Reassigning to that package.  As far as I can tell that symbol should be provided by gstreamer-plugins-base

--- Additional comment from johnp@redhat.com on 2011-03-09 14:04:23 EST ---

Woops, lets reassign that again.

--- Additional comment from lfarkas@lfarkas.org on 2011-03-09 17:12:32 EST ---

and i don't know why i was add either?

--- Additional comment from endoflife@fedoraproject.org on 2012-08-16 09:30:35 EDT ---

This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 1 Stan King 2012-08-24 00:31:00 EDT
After updating to the following components:

libcrystalhd-3.10.0-2.fc17.i686
crystalhd-firmware-3.10.0-2.fc17.noarch
gstreamer-plugin-crystalhd-3.10.0-2.fc17.i686

the output of "gst-inspect -b" is reduced to the following:

Blacklisted files:
  libgstpython.so

Total count: 1 blacklisted file

Does this mean the problem is solved?

So far, there seems to be no h.264 acceleration.

Any tips on further testing would be appreciated.
Comment 2 Nicolas Chauvet (kwizart) 2012-08-30 16:31:58 EDT
If you have a crystalhd device, you could have video accelerated, but then it will need an new kernel device not merged into the mainline kernel
This problem is discussed here:
http://lists.fedoraproject.org/pipermail/kernel/2012-August/003943.html
Comment 3 Stan King 2012-08-31 16:18:38 EDT
Nicolas, thanks for the info.  It's too bad about it, as the accelerator co-processor concept has some potential.  Even one of my desktop machines has a place where one of these could be plugged in.

I had seen the "warning" about the kernel driver many times, but I had assumed that progress had been made somewhere that could be factored into Fedora, as stand-alone XBMC seemed to successfully accelerate video the last time I tried it.

Note You need to log in before you can comment on or make changes to this bug.