Bug 849859 - Bot should restore the needinfo flag after vendor entered the leverage IDs.
Bot should restore the needinfo flag after vendor entered the leverage IDs.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Certification Program
Classification: Red Hat
Component: Certification Workflow Engine (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Feng Wang
Suprith Gangawar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 02:29 EDT by Jianwei Weng
Modified: 2015-11-30 02:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 02:40:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Weng 2012-08-21 02:29:47 EDT
https://hardware.redhat.com/show_activity.cgi?id=836295
https://hardware.redhat.com/show_activity.cgi?id=836299

gregg.shick@hp.com entered some leverage IDs on 2012-08-14,Bot did nothing after that,since the last_update_person is non-reviewer,bot should place a comment there for attention and restore the needinfo flag on reviewer.
Comment 1 Rob Landry 2012-08-21 12:52:33 EDT
This is actually a catalog bug I think.  Setting needinfo on weishen.
Comment 2 Wei Shen 2012-08-21 20:24:34 EDT
It can be easier to fix it on hwcertbot side
Comment 3 Rob Landry 2012-08-21 20:25:48 EDT
but that means there a gap between when the work is entered (process.cgi) and when the work is identified, when hwcertbot goes to reset some flags.
Comment 4 Wei Shen 2012-08-21 20:33:15 EDT
(In reply to comment #3)
> but that means there a gap between when the work is entered (process.cgi)
> and when the work is identified, when hwcertbot goes to reset some flags.

right, now all changes to hwcert data won't be recorded in bz db and the bot currently depends on bz data, so there is a gap
Comment 5 Rob Landry 2012-08-21 20:44:03 EDT
Catalog knows about both table sets so it should be able to set the flag when the testplan table changes resolving the gap.
Comment 6 Wei Shen 2012-08-21 20:49:00 EDT
bot just cares about the last update person, if catalog sets flag on each action, it doesn't make sense
Comment 7 Rob Landry 2012-08-21 21:15:48 EDT
Is the leverage work flag being properly set when the vendor adds the leverage id's by the catalog?
Comment 8 Wei Shen 2012-08-21 21:30:11 EDT
(In reply to comment #7)
> Is the leverage work flag being properly set when the vendor adds the
> leverage id's by the catalog?

Yes, it works,but bot doesn't deal with leverage certs without needinfo, which is a bug
Comment 9 Rob Landry 2012-08-21 21:31:39 EDT
Ah, I see.  Is there any reason why needinfo is required in addition to leverage?  Seems like removing that dependency would be the fix?
Comment 12 Feng Wang 2015-11-30 02:40:01 EST
According to reviewers, this is fixed and moved to Done.

Note You need to log in before you can comment on or make changes to this bug.