Bug 849862 - Need to send cart_data and connection_url property in rhc domain show
Need to send cart_data and connection_url property in rhc domain show
Status: CLOSED DUPLICATE of bug 850544
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 02:34 EDT by Jianwei Hou
Modified: 2015-05-14 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 15:43:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-08-21 02:34:46 EDT
Description of problem:
Run rhc domain show, some of the embedded cartridges' urls are not displayed due to cart_data and connection_url property not sent.

These cartriges include:
phpmyadmin-1.1
10gen-mms-agent-0.1
metrics-0.1

Version-Release number of selected component (if applicable):
devenv_2038
cli: rhc-0.97.13

How reproducible:
Always

Steps to Reproduce:
1.Create domain and create apps, embed cartridge
2.run 'rhc domain show'
  
Actual results:
Some of the cartridges' urls are not displayed

User Info
=========
Namespace: 1038t1

Login: jhou@redhat.com

Namespace 1038t1's Applications
===============================
p1
    Framework: php-5.3
     Creation: 2012-08-21T02:26:07-04:00
         UUID: af18f734b21a40f88745255a839128f1
      Git URL: ssh://af18f734b21a40f88745255a839128f1@p1-1038t1.dev.rhcloud.com/~/git/p1.git/
   Public URL: http://p1-1038t1.dev.rhcloud.com/
   Cartridges:
       10gen-mms-agent-0.1
       mysql-5.1 - mysql://127.0.252.1:3306/
       mongodb-2.0 - mongodb://127.0.252.1:27017/
       metrics-0.1
       phpmyadmin-3.4
       phpmoadmin-1.0 - https://p1-1038t1.dev.rhcloud.com/phpmoadmin/
       rockmongo-1.1 - https://p1-1038t1.dev.rhcloud.com/rockmongo/


Expected results:
Should display all cartridges' url connections if they have one.

Additional info:
see bug 847723
https://bugzilla.redhat.com/show_bug.cgi?id=847723
Comment 1 John (J5) Palmieri 2012-08-21 13:05:00 EDT
Each cart needs to export this as part of the json they send back

{'properties': [{'name': 'connection_url', 'type': 'cart_data', 'value': '...},]}
Comment 2 John Poelstra 2012-08-21 13:11:04 EDT
expecting fix today
Comment 3 Lili Nader 2012-08-21 15:43:25 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=850544

*** This bug has been marked as a duplicate of bug 850544 ***

Note You need to log in before you can comment on or make changes to this bug.