Bug 849886 - [bootstrap] ovirt-engine install node fails because installation of libjpeg
[bootstrap] ovirt-engine install node fails because installation of libjpeg
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Dan Kenigsberg
Haim
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 03:27 EDT by Royce Lv
Modified: 2014-01-12 19:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 06:55:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Royce Lv 2012-08-21 03:27:08 EDT
Description of problem:
On my FC17 x86_64 machine installed a VPN software agnclient.i386(there is no x86_64 package). It depends on package "libjpeg-turbo.i686"

When engine install this machine, it fails because needs to install package "libjpeg.x86_64" which depends on package "libjpeg-turbo.x86_64"

Yum will shout out with:
Error: Protected multilib versions: libjpeg-turbo-1.2.1-1.fc17.x86_64 != libjpeg-turbo-1.2.0-1.fc17.i686

We need to add "--setopt=protected_multilib=false" option when calling yum

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alon Bar-Lev 2013-03-12 06:55:03 EDT
Solved by moving into yum api.

Note You need to log in before you can comment on or make changes to this bug.