This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 849889 - [RHEVM] [backend] 3.0 cluster does not close the detach dialog in case of an error
[RHEVM] [backend] 3.0 cluster does not close the detach dialog in case of an ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alona Kaplan
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 03:35 EDT by Martin Pavlik
Modified: 2016-02-10 14:46 EST (History)
10 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (24.47 KB, application/x-gzip)
2012-08-21 03:35 EDT, Martin Pavlik
no flags Details
screenshot 1 (215.14 KB, image/png)
2012-08-21 03:44 EDT, Martin Pavlik
no flags Details
screenshot 2 (250.56 KB, image/png)
2012-08-21 03:44 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-08-21 03:35:22 EDT
Created attachment 605865 [details]
vdsm.log + engine.log

Description of problem:

1) DC/CL 3.0 variables ${action} ${type} are not substituted on required cluster network detach

The following error message appears (see screenshot 1):
DC/CL 3.0 variables ${action} ${type} are not substitued on required cluster network detach

2) When user closes the wrong error message, rhevm displays Detach Network Interfaces dialog again. This does not make sense since user can go only with cancel button. (clicking OK button will take user back to wrong error message). (screenshot 2)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-12.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1.Create Data Center 3.0 with cluster in it, add host
2.Create required logical network and attach it to host interface
3.Activate the hos
4.Hosts -> your host -> network interfaces -> interface with LN from step 2 -> Detach -> click OK -> wrong error message appears (see screenshot1)
  
Actual results:
1)variables ${action} ${type} are not substituted; 
2)When user closes the wrong error message, rhevm displays Detach Network Interfaces dialog again (see screenshot2)

Expected results:
1)variables ${action} ${type} are substitued with apropriate values;
2)When user closes the wrong error message, rhevm does NOT display Detach Network Interfaces dialog again

Additional info:


2012-08-21 09:21:17,912 WARN  [org.ovirt.engine.core.bll.DetachNetworkFromVdsInterfaceCommand] (ajp-/127.0.0.1:8009-2) [31ba66a] CanDoAction of action DetachNetworkFromVdsInterface failed. Reasons:NETWORK_CLUSTER_NETWORK_IN_USE
Comment 1 Martin Pavlik 2012-08-21 03:44:20 EDT
Created attachment 605866 [details]
screenshot 1
Comment 2 Martin Pavlik 2012-08-21 03:44:38 EDT
Created attachment 605867 [details]
screenshot 2
Comment 7 Alona Kaplan 2012-08-27 11:03:42 EDT
upstream commit 69d99bfd9f91f643411f1e3da9a51459ca35589b

Note You need to log in before you can comment on or make changes to this bug.