Bug 849895 - rhel7.0 & rhel6.3 guest fail to boot with the qcow image converted from raw by qcow-create(img2qcow)
rhel7.0 & rhel6.3 guest fail to boot with the qcow image converted from raw b...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 03:47 EDT by Wei Shi
Modified: 2012-08-29 06:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 05:41:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Shi 2012-08-21 03:47:50 EDT
Description of problem:
Launch a rhel7.0|rhel6.3 guest with qcow image(use either qcow-create or img2qcow) will lead to can't found filesystem error(image either using lvm or without lvm), but system startup normally with the original raw image.
Same problem will not arise if i install the OS directly on qcow image, OS can boot up normally with the qcow image.
These problem won't arise on rhel6.2 x86_64 HVM, i have tried.

Version-Release number of selected component (if applicable):
Host  : RHEL5.9 2.6.18-336.el5xen
Guest : RHEL7.0(3.3.0-0.20.el7.x86_64) & RHEL6.3(2.6.32-279.el6.x86_64)HVM
Xen   : xen-3.0.3-140.el5 (qcow-create img2qcow)
Dracut: dracut-018-65.git20120612.el7.noarch  (rhel7.0)
        dracut-004-283.el6.noarch             (rhel6.3)
        dracut-004-256.el6.noarch             (rhel6.2)

How reproducible:
100%

Steps to Reproduce:
Scenario 1:
1. Fetch a prepared rhel raw image from nfs(using lvm+loopback)
2. Create qcow image base on the raw image
   qcow-create 10000 [ qcow_image ] [ raw_image ]
3. Launch guest domain with the qcow image

Scenario 2:
1. Fetch a prepared rhel raw image from nfs(using lvm+blktap)
2. Create qcow image base on the raw image
   qcow-create 10000 [ qcow_image ] [ raw_image ]
3. Launch guest domain with the qcow image

Scenario 3:
1. Fetch a prepared rhel raw image from nfs(using lvm+loopback)
2. Create qcow image base on the raw image
   img2qcow [ qcow_image ] [ raw_image ]
3. Launch guest domain with the qcow image

Scenario 4:
1. Do a fresh rhel6.3 installation using raw image(without lvm)
2. Create qcow image base on the raw image
   qcow-create 10000 [ qcow_image ] [ raw_image ]
3. Launch guest domain with the qcow image

Scenario 5(in this case things work as we expect):
1. Create qcow image base on the raw image
   qcow-create -r 10000 [ qcow_image ]
2. Do a fresh rhel6.3 installation using qcow image(with lvm+loopback)
3. Launch guest domain with the qcow image

Actual results:
filesystem can't be mounted normally



********* RHEL7.0 boot up error snapshot(Scenario 1): *********
[   42.102651] dracut Warning: Unable to process initqueue
dracut Warning: Unable to process initqueue
Cannot open font file True
dracut Warning: Unable to process initqueue
[   42.144646] dracut Warning: /dev/mapper/vg_rhel7-lv_root does not exist
dracu[   42.154944] dracut Warning: /dev/vg_rhel7/lv_root does not exist
t Warning: /d[   42.164725] dracut Warning: /dev/vg_rhel7/lv_swap does not exist
ev/mapper/vg_rhel7-lv_root does not exist
dracut Warning: /dev/vg_rhel7/lv_root does not exist
dracut Warning: /dev/vg_rhel7/lv_swap does not exist
Dropping to debug shell.
dracut:/#



********* RHEL6.3 boot up error snapshot(Scenario 1): *********
ata2: PATA max MWDMA2 cmd 0x170 ctl 0x376 bmdma 0xc008 irq 15
input: ImExPS/2 Generic Explorer Mouse as /devices/platform/i8042/serio1/input/input2
xlblk_init: register_blkdev major: 202
blkfront: xvda: barriers disabled
 xvda: unknown partition table
dracut Warning: No root device "block:/dev/mapper/vg_dhcp8202-lv_root" found
dracut Warning: LVM vg_dhcp8202/lv_root not found
dracut Warning: LVM vg_dhcp8202/lv_swap not found
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
dracut Warning: Signal caught!
dracut Warning: LVM vg_dhcp8202/lv_root not found
dracut Warning: LVM vg_dhcp8202/lv_swap not found
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-279.el6.x86_64 #1
Call Trace:
 [<ffffffff814fd11a>] ? panic+0xa0/0x168
 [<ffffffff81070bd2>] ? do_exit+0x862/0x870
 [<ffffffff8117ca75>] ? fput+0x25/0x30
 [<ffffffff81070c38>] ? do_group_exit+0x58/0xd0
 [<ffffffff81070cc7>] ? sys_exit_group+0x17/0x20
 [<ffffffff8100b0f2>] ? system_call_fastpath+0x16/0x1b




********* RHEL6.3 boot up error snapshot(Scenario 2): *********
udevd[116]: worker [191] failed while handling '/devices/vbd-768'
udevd[116]: worker [171] unexpectedly returned with status 0x0100
udevd[116]: worker [171] failed while handl
ing '/dserial8250: too much work for irq4
evices/platform/Fixed MDIO bus.0'
udevd[116]: worker [164] unexpectedly returned with status 0x0100
udevd[116]: worker [164] failed while handling '/devices/platform/i8042/serio1/input/input2'
udevd[116]: worker [221] unexpectedly returned with status 0x0100
udevd[116]: worker [221] failed while handling '/devices/virtual/dmi/id'
120s...115s...110s...105s...100s...
dracut Warning: No root device "block:/dev/mapper/vg_dhcp8202-lv_root" found
udevd[116]: worker [191] unexpectedly returned with status 0x0100
udevd[116]: worker [191] failed while handling '/devices/vbd-768'
udevd[116]: worker [171] unexpectedly returned with status 0x0100
udevd[116]: worker [171] failed while haserial8250: too much work for irq4
ndling '/devices/platform/Fixed MDIO bus.0'
udevd[116]: worker [164] unexpectedly returned with status 0x0100
udevd[116]: worker [164] failed while handling '/devices/platform/i8042/serio1/input/input2'
udevd[116]: worker [221] unexpectedlyserial8250: too much work for irq4
 returned with status 0x0100
udevd[116]: worker [221] failed while handling '/devices/virtual/dmi/id'
dracut Warning: LVM vg_dhcp8202/lv_root not found
dracut Warning: LVM vg_dhcp8202/lv_swap not found
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
dracut Warning: Signal caught!
dracut Warning: LVM vg_dhcp8202/lv_root not found
dracut Warning: LVM vg_dhcp8202/lv_swap not found
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-279.el6.x86_64 #1
Call Trace:
 [<ffffffff814fd11a>] ? panic+0xa0/0x168
 [<ffffffff81070bd2>] ? do_exit+0x862/0x870
 [<ffffffff8117ca75>] ? fput+0x25/0x30
 [<ffffffff81070c38>] ? do_group_exit+0x58/0xd0
 [<ffffffff81070cc7>] ? sys_exit_group+0x17/0x20
 [<ffffffff8100b0f2>] ? system_call_fastpath+0x16/0x1b





********* RHEL6.3 boot up error snapshot(Scenario 4): *********
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/00:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
dracut Warning: No root device "block:/dev/disk/by-uuid/208c81eb-5acb-4ae2-830f-1e50e3b6c8b0" found
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
dracut Warning: Signal caught!
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-279.el6.x86_64 #1
Call Trace:
 [<ffffffff814fd11a>] ? panic+0xa0/0x168
 [<ffffffff81070bd2>] ? do_exit+0x862/0x870
 [<ffffffff8117ca75>] ? fput+0x25/0x30
 [<ffffffff81070c38>] ? do_group_exit+0x58/0xd0
 [<ffffffff81070cc7>] ? sys_exit_group+0x17/0x20
 [<ffffffff8100b0f2>] ? system_call_fastpath+0x16/0x1b
Comment 2 RHEL Product and Program Management 2012-08-21 04:18:24 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 Miroslav Rezanina 2012-08-23 08:06:38 EDT
Testing shows that this problem is reproducible even with 6.2. Testing images uses different configuration - 6.2 has xen_emul_unplug=never and 6.3 uses xen_emul_unplug=ide-disks. 

When using pv-on-hvm drivers with emulated drivers unplugged, block drive does not find the disk so system fail with no hard disk.
Comment 7 Paolo Bonzini 2012-08-27 05:46:58 EDT
Can you attach the Xen domain configuration file (either the XML for libvirt, or the one for xm)?
Comment 8 Miroslav Rezanina 2012-08-27 06:23:38 EDT
Any standard config file works, I'm reproducing the problem with this xen config:

name = "bz849895_3"
uuid = "22e45cd6-8bdd-61e5-7679-d3e1e8a7afd1"
maxmem = 1024
memory = 1024
vcpus = 2
builder = "hvm"
kernel = "/usr/lib/xen/boot/hvmloader"
boot = "c"
pae = 1
acpi = 1
apic = 1
localtime = 0
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "preserve"
device_model = "/usr/lib64/xen/bin/qemu-dm"
sdl = 0
vnc = 1
vncunused = 1
keymap = "en-us"
disk = [ "file:/var/lib/xen/images/lws/bz849896/RHEL-Server-6.2-64-hvm2.qcow,hda,w", ",hdc:cdrom,r" ]
vif = [ "mac=00:16:3e:6c:e3:0c,bridge=virbr0,script=vif-bridge" ]
parallel = "none"
serial = "pty"


Important part is disk configuration. There's 4 possible settings:

1] file:/var/lib/xen/images/lws/bz849896/RHEL-Server-6.2-64-hvm2.qcow,hda,w
2] file:/var/lib/xen/images/lws/bz849896/RHEL-Server-6.2-64-hvm2.qcow,xvda,w
3] tap:qcow:/var/lib/xen/images/lws/bz849896/RHEL-Server-6.2-64-hvm2.qcow,hda,w
4] tap:qcow:/var/lib/xen/images/lws/bz849896/RHEL-Server-6.2-64-hvm2.qcow,xvda,w

I've got following results:
1 & 2 - Lot's of ata errors and crash
3 & 4 - XENBUS: Waiting for devices to initialize error with countdown, since 100s ata errors, and than crash

Error Output (option 2):

xlblk_init: register_blkdev major: 202 
blkfront: xvda: barriers disabled
vbd vbd-5632: 19 xenbus_dev_probe on device/vbd/5632
 xvda: unknown partition table
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: CDB: Mode Sense(10): 5a 00 2a 00 00 00 00 00 80 00
ata2.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 16512 in
         res 48/20:02:00:1c:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.20
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: BMDMA stat 0x5
sr 1:0:0:0: [sr0] CDB: Inquiry: 12 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
ata2.00: configured for MWDMA2
ata2: EH complete
dracut Warning: No root device "block:/dev/mapper/vg_virtlab668438-lv_root" found




ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
dracut Warning: LVM vg_virtlab668438/lv_root not found
dracut Warning: LVM vg_virtlab668438/lv_swap not found
ata2.00: BMDMA stat 0x5

sr 1:0:0:0: [sr0] CDB: Inquiry
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
:
  12
dracut Warning: Signal caught!

 00 00 00 fe 00
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         res 48/20:02:00:24:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
ata2.00: status: { DRDY DRQ }
ata2: soft resetting link
dracut Warning: LVM vg_virtlab668438/lv_root not found
dracut Warning: LVM vg_virtlab668438/lv_swap not found
dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.

Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32-220.el6.x86_64 #1
Call Trace:
 [<ffffffff814ec341>] ? panic+0x78/0x143
 [<ffffffff8106eed2>] ? do_exit+0x852/0x860
 [<ffffffff81177fc5>] ? fput+0x25/0x30
 [<ffffffff8106ef38>] ? do_group_exit+0x58/0xd0
 [<ffffffff8106efc7>] ? sys_exit_group+0x17/0x20
 [<ffffffff8100b0f2>] ? system_call_fastpath+0x16/0x1b
Comment 9 Paolo Bonzini 2012-08-27 07:33:28 EDT
Looks like the same bug that was reported with xenpv-win (bug 452299).
Comment 10 Miroslav Rezanina 2012-08-29 03:16:46 EDT
Ok, one day of testing to remember we decided to not backport change for backing file. So we support only qcow on qcow (unlike the upstream that supports qcow on raw). Using raw as backing file is not supported and fails everytime. 

I have to check why the img2qcow scenario fails.
Comment 11 Miroslav Rezanina 2012-08-29 04:14:36 EDT
Can you please retest the Scenario 3 with ensuring tap:qcow is used for disk configuration. It's working for me. 

You can't use file: as you're trying to use only pv-on-hvm - image does not go through proper blktap path and is not opened correctly.
Comment 12 Wei Shi 2012-08-29 05:17:49 EDT
(In reply to comment #11)
> Can you please retest the Scenario 3 with ensuring tap:qcow is used for disk
> configuration. It's working for me. 
> 
> You can't use file: as you're trying to use only pv-on-hvm - image does not
> go through proper blktap path and is not opened correctly.

Passed for img2qcow
[root@dhcp-8-204 images]# img2qcow RHEL-Server-6.3-64-hvm.qcow RHEL-Server-6.3-64-hvm.raw
Image size: [16386048]
Created cksum: -1000528405
File truncated to length 8391741952
Qcow file created: size 16386048 sectors
[=====================]     100%
TRANSFER COMPLETE

Writing cksum: 833943482

1. disk = ['tap:qcow:/root/xen.autotest/client/tests/xen/images/RHEL-Server-6.3-64-hvm.qcow,hda,w']
2. disk = ['tap:qcow:/root/xen.autotest/client/tests/xen/images/RHEL-Server-6.3-64-hvm.qcow,xvda,w']

Failed case in Scenario 3 is because using the following combination as you describe in c6
xen_emul_unplug=ide-disks
disk = ['file:/root/xen.autotest/client/tests/xen/images/RHEL-Server-6.3-64-hvm.qcow,hda,w']
Comment 13 Miroslav Rezanina 2012-08-29 05:41:53 EDT
Closing this bz as NOTABUG. Failures was caused by using unsupported configurations:

1.) Using raw image as backing file is not supported. Only qcow image is supported as backing file

2.) Using qcow image with loopback configuration and pv-on-hvm drivers only. This can't work as image is not properly handled by blktapctrl deamon.

Note You need to log in before you can comment on or make changes to this bug.